Opened 4 years ago

Closed 4 years ago

#1002 closed defect (worksforme)

worker process 9255 exited on signal 11 (core dumped)

Reported by: Bruno Bigras Owned by:
Priority: minor Milestone:
Component: other Version: 1.9.x
Keywords: Cc:
uname -a: Linux ubuntunew 3.13.0-88-generic #135-Ubuntu SMP Wed Jun 8 21:10:37 UTC 2016 i686 i686 i686 GNU/Linux
nginx -V: nginx version: nginx/1.11.1
built by gcc 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.3)
built with OpenSSL 1.0.1f 6 Jan 2014
TLS SNI support enabled
configure arguments: --add-module=/home/bbigras/nginx/nginx-1.11.1/debian/modules/naxsi/naxsi_src --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-http_auth_request_module --with-http_xslt_module=dynamic --with-http_image_filter_module=dynamic --with-http_geoip_module=dynamic --with-http_perl_module=dynamic --add-dynamic-module=debian/extra/njs-1c50334fbea6/nginx --with-threads --with-stream --with-stream_ssl_module --with-http_slice_module --without-mail_pop3_module --without-mail_imap_module --without-mail_smtp_module --add-module=/home/bbigras/nginx/nginx-1.11.1/debian/modules/ngx_devel_kit --add-module=/home/bbigras/nginx/nginx-1.11.1/debian/modules/lua-nginx-module --add-module=/home/bbigras/nginx/nginx-1.11.1/debian/modules/nginx-auth-ldap --add-module=/home/bbigras/nginx/nginx-1.11.1/debian/modules/nchan --with-file-aio --with-ipv6 --with-http_v2_module --with-cc-opt='-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security' --with-ld-opt='-Wl,-Bsymbolic-functions -Wl,-z,relro'

Description

I have no idea what happened and how to reproduce.

I think I only had this crash once since I updated to 1.11.1 the day it was released.

Reading symbols from /usr/sbin/nginx...Reading symbols from /usr/lib/debug/.build-id/22/52597e56bb163e96e29c7a63ff78829cb2444d.debug...done.
done.
[New LWP 9255]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
Core was generated by `nginx: worker process                   '.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  ngx_rbtree_min (sentinel=0x8203a10 <ngx_event_timer_sentinel>, node=0x0) at src/core/ngx_rbtree.h:74
74          while (node->left != sentinel) {
(gdb) bt
#0  ngx_rbtree_min (sentinel=0x8203a10 <ngx_event_timer_sentinel>, node=0x0) at src/core/ngx_rbtree.h:74
#1  ngx_event_find_timer () at src/event/ngx_event_timer.c:45
#2  0x0807facd in ngx_process_events_and_timers (cycle=cycle@entry=0x9f8e4e8) at src/event/ngx_event.c:204
#3  0x08086216 in ngx_worker_process_cycle (cycle=0x9f8e4e8, data=0x1) at src/os/unix/ngx_process_cycle.c:753
#4  0x08084c46 in ngx_spawn_process (cycle=cycle@entry=0x9f8e4e8, proc=proc@entry=0x8086190 <ngx_worker_process_cycle>, data=data@entry=0x1, name=name@entry=0x8174f9f "worker process",
    respawn=respawn@entry=-3) at src/os/unix/ngx_process.c:198
#5  0x080863f3 in ngx_start_worker_processes (cycle=cycle@entry=0x9f8e4e8, n=2, type=type@entry=-3) at src/os/unix/ngx_process_cycle.c:358
#6  0x08086de0 in ngx_master_process_cycle (cycle=cycle@entry=0x9f8e4e8) at src/os/unix/ngx_process_cycle.c:130
#7  0x080639ae in main (argc=3, argv=0xbf8c2a64) at src/core/nginx.c:367
2016/06/21 15:40:19 [error] 9255#9255: REDIS_REPLY_ERROR: Subscriber count for channel /apresPost less than zero: -1
2016/06/21 15:40:40 [notice] 16749#16749: http_auth_ldap: parse_require in /etc/nginx/sites-enabled/git.app.local:5
2016/06/21 15:40:40 [notice] 16749#16749: http_auth_ldap: Setting group in /etc/nginx/sites-enabled/git.app.local:5
2016/06/21 15:40:40 [notice] 16749#16749: http_auth_ldap: parse_require in /etc/nginx/sites-enabled/git.app.local:14
2016/06/21 15:40:40 [notice] 16749#16749: http_auth_ldap: Setting group in /etc/nginx/sites-enabled/git.app.local:14
2016/06/21 15:40:40 [info] 16749#16749: Using 32768KiB of shared memory for nchan in /etc/nginx/nginx.conf:83
2016/06/21 15:41:16 [alert] 9253#9253: worker process 9255 exited on signal 11 (core dumped)
2016/06/21 15:41:16 [error] 16882#16882: IPC:got IPC alert delayed by 9 sec
2016/06/21 15:45:40 [notice] 18412#18412: http_auth_ldap: parse_require in /etc/nginx/sites-enabled/git.app.local:5
2016/06/21 15:45:40 [notice] 18412#18412: http_auth_ldap: Setting group in /etc/nginx/sites-enabled/git.app.local:5
2016/06/21 15:45:40 [notice] 18412#18412: http_auth_ldap: parse_require in /etc/nginx/sites-enabled/git.app.local:14
2016/06/21 15:45:40 [notice] 18412#18412: http_auth_ldap: Setting group in /etc/nginx/sites-enabled/git.app.local:14
2016/06/21 15:45:40 [info] 18412#18412: Using 32768KiB of shared memory for nchan in /etc/nginx/nginx.conf:83

Change History (2)

comment:1 by Valentin V. Bartenev, 4 years ago

Could you reproduce it without 3rd-party modules?

comment:2 by Maxim Dounin, 4 years ago

Resolution: worksforme
Status: newclosed

Feedback timeout. Looks like a problem in a 3rd party module.

Note: See TracTickets for help on using tickets.