Opened 4 years ago

Closed 4 years ago

#1028 closed defect (worksforme)

Build failure on debian-kbsd

Reported by: MTecknology@… Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.10.x
Keywords: Cc:
uname -a:
nginx -V: yes

Description

Downstream bug report: https://bugs.debian.org/826061

The patch that resolves the build failure in Debian has been attached. It will be relevant to more than just Debian.

Attachments (1)

0003-define_gnu_source-on-other-glibc-based-platforms.patch (532 bytes ) - added by MTecknology@… 4 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 by Maxim Dounin, 4 years ago

I can't confirm. While nginx does not recognize Debian/kFreeBSD, it compiles fine on it. Just tested on freshly downloaded debian-testing image. Just for the record, here is what uname -a shows:

GNU/kFreeBSD debian-kfreebsd 10.1-0-686 #0 Tue, 07 Apr 2015 22:13:19 +0100 i386 i386 Intel(R) Core(TM) i5-2557M CPU @ 1.70GHz GNU/kFreeBSD

Note well that configure results as available in the bug in question contain different results for the same configure tests, notably:

checking for accept4() ... not found
checking for accept4() ... found

It looks like there is something wrong with the build environment which makes configure results incorrect. The patch suggested hides the problem, but not fixes the root cause.

comment:2 by Maxim Dounin, 4 years ago

Resolution: worksforme
Status: newclosed

Feedback timeout. As previously suggested, this looks like a problem with the build environment.

Note: See TracTickets for help on using tickets.