Opened 9 years ago

Closed 9 years ago

#109 closed defect (worksforme)

mp4 fails to stream after positioning to unloaded portion of the clip

Reported by: Danila Sukharev Owned by: somebody
Priority: major Milestone:
Component: nginx-core Version: 1.0.x
Keywords: Cc:
uname -a: Linux x220 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Linux x220 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Linux x220 3.0.0-15-generic #26-Ubuntu SMP Fri Jan 20 17:23:00 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.0.12
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx/ --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-mail --with-mail_ssl_module --with-file-aio --with-ipv6

Description

Steps:

  1. Setup nginx for mp4 streaming using the default config from docs.
  2. Open streamed mp4 file in flowplayer or jwplayer.
  3. Position to the center of the clip.

NOTE: you should position to the uncached part of the clip to reproduce the bug. It's hard to do this locally due to very high load speed.

Happened: video playback fails to resume (at about 80% of the cases) only sound plays.
Expected: normal playback after positioning.

tested on win 1.1.15 / win 1.0.12 / linux64 1.0.12 - behavior is the same.

Comments:

  1. Tried with the same clip and apache2 with h264 streaming module - works fine.
  2. I also found the way to reproduce the issue using local web-server and local mplayer.

Steps:

result: everything is almost OK, BUT note that for about 0.5/1 sec video is distorted (until the key frame) - there is no such behavior on apache2+streaming, everything works fine with apache

  • try to fast forward the clip using "right" button on the keyboard.

result: video playback stopped with a lot of errors in mplayer log - there is no such behavior on apache2+streaming, everything works fine with apache

-- Dan

Change History (2)

comment:1 by Maxim Dounin, 9 years ago

Could you please provide sample mp4 which exhibits the problem?

Note 1: local reproduction should be easy with something like "limit_rate 100k;" in config.

Note 2: suggested reproduction with "?start=600" looks invalid, as players are expected to seek to key frames (and do so). Seeking to an arbitrary position will expectedly cause video distortion before first keyframe, and may cause other problems as well.

comment:2 by Maxim Dounin, 9 years ago

Resolution: worksforme
Status: newclosed

Feedback timeout.

Note: See TracTickets for help on using tickets.