Opened 2 years ago

Closed 2 years ago

#1141 closed defect (duplicate)

duplicate "60394" address and port pair in /etc/nginx/nginx.conf

Reported by: wrfly@… Owned by:
Priority: critical Milestone:
Component: nginx-core Version: 1.9.x
Keywords: duplicated port Cc:
uname -a: Linux e65b7c160703 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.9.13 (nginx-plus-extras-r9-p1) built by gcc 4.9.2 (Debian 4.9.2-10) built with OpenSSL 1.0.1k 8 Jan 2015 (running with OpenSSL 1.0.1t 3 May 2016) TLS SNI support enabled configure arguments: --build=nginx-plus-extras-r9-p1 --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_f4f_module --with-http_hls_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_session_log_module --with-http_stub_status_module --with-http_auth_request_module --with-http_slice_module --with-mail --with-mail_ssl_module --with-threads --with-file-aio --with-http_v2_module --with-ipv6 --with-stream --with-stream_ssl_module --with-http_perl_module --with-http_image_filter_module --with-http_geoip_module --with-http_xslt_module --add-module=extra/ngx_devel_kit-0.3.0rc1 --add-module=extra/set-misc-nginx-module-0.30 --add-module=extra/lua-nginx-module-0.10.2 --add-module=extra/headers-more-nginx-module-0.29 --add-module=extra/passenger-5.0.26/src/nginx_module --add-module=extra/nginx-rtmp-module-1.1.7 --with-cc-opt='-g -O2 -fstack-protector-strong -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-z,relro -Wl,--as-needed'

Description

# nginx -t
2016/11/22 13:11:11 [emerg] 1#1: duplicate "60394" address and port pair in /etc/nginx/nginx.conf:28
nginx: [emerg] duplicate "60394" address and port pair in /etc/nginx/nginx.conf:28
nginx: configuration file /etc/nginx/nginx.conf test failed

nginx.conf:

worker_processes auto;
error_log /var/log/nginx/error.log notice;
pid /var/run/nginx.pid;
events {

worker_connections 65535;

}

http{

server {

listen 8080;
root /usr/share/nginx/html;

}

}

stream {

upstream bbb {

server 10.10.8.8:60139;

}
server {

listen 60139;
proxy_pass bbb;

}

upstream aaa {

server 10.10.8.8:60394;

}
server {

listen 60394;
proxy_pass aaa;

}

}

Change History (1)

comment:1 Changed 2 years ago by mdounin

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1021.

Note: See TracTickets for help on using tickets.