Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1231 closed defect (invalid)

Testconfig using filename doesn't test includes

Reported by: serban.constantin@… Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.10.x
Keywords: config test Cc: serban.constantin@…
uname -a: Linux hostname 3.10.0-327.22.2.el7.x86_64 #1 SMP Thu Jun 23 17:05:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.10.2
built by gcc 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC)
built with OpenSSL 1.0.1e-fips 11 Feb 2013
TLS SNI support enabled
configure arguments: --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib64/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/tmp/client_body --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --pid-path=/run/nginx.pid --lock-path=/run/lock/subsys/nginx --user=nginx --group=nginx --with-file-aio --with-ipv6 --with-http_ssl_module --with-http_v2_module --with-http_realip_module --with-http_addition_module --with-http_xslt_module=dynamic --with-http_image_filter_module=dynamic --with-http_geoip_module=dynamic --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_degradation_module --with-http_slice_module --with-http_stub_status_module --with-http_perl_module=dynamic --with-mail=dynamic --with-mail_ssl_module --with-pcre --with-pcre-jit --with-stream=dynamic --with-stream_ssl_module --with-google_perftools_module --with-debug --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic' --with-ld-opt='-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-E'

Description

It looks like when testing a specific configuration file using -t -c /path/to/test/nginx.conf the test doesn't go over the includes in that configuration file.

Attached are the config files used to test. The test should fail as both server.example and shouldfail.example have a duplicate default server for 0.0.0.0:80

When saving the files directly in /etc/nginx and running nginx -t the test does indeed fail.

When saving the config files in a different folder (say ~/testconfig) and running as nginx -t -c ~/testconfig/nginx.conf it doesn't fail, as the includes from the config file aren't tested.

Reproducibility steps:

  1. extract the repro.zip
  2. test contents using nginx -t -c /path/to/repro/nginx.conf
  3. test passes despite the fact that it should fail
  4. move conf files to nginx install (for example /etc/nginx)
  5. test using nginx -t
  6. test fails

The test should fail in both cases: when using the -c flag as well as normally without it.

Attachments (1)

repro.zip (1.9 KB ) - added by serban.constantin@… 3 years ago.
files used to reproduce issue

Download all attachments as: .zip

Change History (3)

by serban.constantin@…, 3 years ago

Attachment: repro.zip added

files used to reproduce issue

comment:1 by Maxim Dounin, 3 years ago

Resolution: invalid
Status: newclosed

The nginx.conf configuration file uses:

    include ./sites-enabled/*;

and there is no sites-enabled directory in the archive, so no files are included.

Changing sites-enabled to sites-available results in expected test failure:

$ nginx -t -c /path/to/repro/nginx.conf
nginx: [emerg] a duplicate default server for 0.0.0.0:80 in /path/to/repro/./sites-available/shouldfail.example:2
nginx: configuration file /path/to/repro/nginx.conf test failed

in reply to:  1 comment:2 by serban.constantin@…, 3 years ago

Replying to mdounin:

You're right, I completely missed that I'm including sites-enabled but that isn't available during the test phase in my workflow.

Note: See TracTickets for help on using tickets.