Opened 3 years ago

Closed 3 years ago

#1245 closed defect (duplicate)

proxy_cache_path should create intermediate directories (recursive, like mkdir -p)

Reported by: heptathlon@… Owned by:
Priority: minor Milestone: 1.12.0
Component: nginx-core Version: 1.11.x
Keywords: folder, directory Cc:
uname -a: -
nginx -V: -

Description

proxy_cache_path should create intermediate directories (recursive, like mkdir -p).

Example:

proxy_cache_path /etc/nginx/cache/non/existing/path/here ...;

should not fail if /etc/nginx/cache/non/existing/path doesn't exist yet, but instead should create /etc/nginx/cache/non/existing/path/here and continue as expected.

This probably doesn't just affect the proxy_cache_path option, but every option where nginx creates a folder.

Change History (1)

comment:1 by Maxim Dounin, 3 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #750.

Note: See TracTickets for help on using tickets.