Opened 2 years ago

Closed 2 years ago

#1251 closed defect (duplicate)

Segmentation fault in special nginx mode

Reported by: eendru@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.6.x
Keywords: Cc:
uname -a: Linux user 4.4.0-42-generic #62~14.04.1-Ubuntu SMP Fri Oct 7 23:15:48 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.6.0 built by gcc 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04) configure arguments: --with-debug

Description

Use config in attachment
I think, that keyword - master_process off;

Run nginx, send some requests via curl or something else. After, send SIGHUP to nginx, send again some requests, you will recive something like

* Rebuilt URL to: 127.0.0.1:9999/

  • Trying 127.0.0.1...
  • Connected to 127.0.0.1 (127.0.0.1) port 9999 (#0)

    GET / HTTP/1.1
    Host: 127.0.0.1:9999
    User-Agent: curl/7.47.0
    Accept: */*

    2017/04/18 13:27:42 [alert] 10307#0: 65536 worker_connections are not enough
    Connection #0 to host 127.0.0.1 left intact


And after send another SIGHUP, and you catch

Program received signal SIGSEGV, Segmentation fault.
0x00000000004105bb in ngx_clean_old_cycles (ev=0x69f280 <ngx_cleaner_event>)

Attachments (1)

nginx.conf (674 bytes) - added by eendru@… 2 years ago.
nginx.conf

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by eendru@…

nginx.conf

comment:1 Changed 2 years ago by eendru@…

As I checked, on new nginx

nginx version: nginx/1.11.13
built by gcc 4.9.4 (Ubuntu 4.9.4-2ubuntu1~14.04.1)
configure arguments: --with-debug

same problem.

  • use master_process off;
  • send requests
  • send sighup
  • send requests(responses won't be received)
  • send sighup
  • send requests

wait less than 20 seconds

Program received signal SIGSEGV, Segmentation fault.
0x000000000041cbda in ngx_clean_old_cycles (ev=0x6bdb80 <ngx_cleaner_event>) at src/core/ngx_cycle.c:1303
1303	            if (cycle[i]->connections[n].fd != (ngx_socket_t) -1) {

Last edited 2 years ago by eendru@… (previous) (diff)

comment:2 Changed 2 years ago by eendru@…

Is duplicate, sorry

comment:3 Changed 2 years ago by mdounin

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #945.

Note: See TracTickets for help on using tickets.