Opened 8 years ago

Closed 8 years ago

#127 closed defect (duplicate)

Can't compile the newest nginx Mac OS X Lion

Reported by: Victor Ng Owned by: somebody
Priority: major Milestone:
Component: nginx-core Version: 1.1.x
Keywords: Cc:
uname -a: Darwin vngs-mac.local 11.3.0 Darwin Kernel Version 11.3.0: Thu Jan 12 18:47:41 PST 2012; root:xnu-1699.24.23~1/RELEASE_X86_64 x86_64
nginx -V: not installed

Description

Cannot compile nginx on Mac OS X Lion.

Getting the following error:

Undefined symbols for architecture x86_64:
  "_pcre_free_study", referenced from:
      _ngx_pcre_free_studies in ngx_regex.o
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
make[1]: *** [objs/nginx] Error 1
make: *** [build] Error 2

Attached please find full log

Attachments (1)

error.log (50.1 KB ) - added by Victor Ng 8 years ago.

Download all attachments as: .zip

Change History (3)

by Victor Ng, 8 years ago

Attachment: error.log added

comment:2 by Ruslan Ermilov, 8 years ago

Resolution: duplicate
Status: newclosed

duplicate of bug#94

Note: See TracTickets for help on using tickets.