Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1420 closed defect (invalid)

URL with long query string

Reported by: riccardo.casatta@… Owned by:
Priority: minor Milestone:
Component: other Version: 1.10.x
Keywords: Cc:
uname -a: Linux frontend 4.4.0-93-generic #116-Ubuntu SMP Fri Aug 11 21:17:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.10.3 (Ubuntu)

Description

When I try to open the link which is served by nginx in this gist https://gist.github.com/RCasatta/b8a9ec2f1e8e6cc539c25f7b1ac77140
The connection is closed
but it works up to 5849 characters in the query string

from the access.log I have something like this
x.x.x.x - - [07/Nov/2017:09:51:50 +0000] "-" 000 0 "-" "-"
and from the error.log I have nothing

I tried to add to the nginx.conf the lines:

client_header_buffer_size 64k;
large_client_header_buffers 4 64k;

but nothing has changed

Change History (2)

comment:1 by Maxim Dounin, 3 years ago

Resolution: invalid
Status: newclosed

Most likely the problem is that you are using HTTP/2 and the request hits the http2_max_field_size limit. Try checking error log at the "info" level, it should contain something like:

2017/11/08 03:46:35 [info] 68639#100081: *2 client exceeded http2_max_field_size limit while processing HTTP/2 connection, client: ..., server: ...

Adjusting the limit should resolve the issue.

comment:2 by riccardo.casatta@…, 3 years ago

I confirm the issue was using the wrong parameter.
Using ​http2_max_field_size fix the problem

Note: See TracTickets for help on using tickets.