Opened 3 years ago

Closed 3 years ago

Last modified 17 months ago

#1493 closed defect (duplicate)

nginx proxy + cloudflare + https = 403 Forbidden cloudflare-nginx

Reported by: f4nff@… Owned by:
Priority: major Milestone:
Component: other Version: 1.13.x
Keywords: proxy https 403 cloudflare Cc:
uname -a:
nginx -V: 1.13.9

Description

upstream ws {
	server 104.16.19.234:443;
	server 104.16.18.234:443;
	server 104.16.10.234:443;
	server 104.16.11.234:443;
 
 }
 
 
 server {
         listen      80; 
 
location /{
	proxy_pass_header	Server;
	proxy_pass			https://ws;
	proxy_set_header	Host "cloudflareapi.com";
	proxy_set_header	X-Real-IP $remote_addr;
	proxy_set_header	X-Scheme $scheme;
		}
	}
403 Forbidden
cloudflare-nginx

Change History (1)

comment:1 by Maxim Dounin, 3 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1492.

Note: See TracTickets for help on using tickets.