Opened 9 years ago

Closed 9 years ago

#153 closed defect (duplicate)

SIGCHLD + SIGIO после обновления с 1.1.17 на 1.1.19

Reported by: openid.yandex.ru/umask Owned by: somebody
Priority: major Milestone:
Component: nginx-core Version: 1.1.x
Keywords: Cc:
uname -a: Linux hostname.ru 2.6.18-308.el5.028stab099.3 #1 SMP Wed Mar 7
15:56:00 MSK 2012 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.1.19
built by gcc 4.1.2 20080704 (Red Hat 4.1.2-52)
TLS SNI support disabled
configure arguments: --prefix=/usr --conf-path=/etc/nginx/nginx.conf
--pid-path=/var/run/nginx/nginx.pid
--error-log-path=/var/log/nginx/error.log
--http-log-path=/var/log/nginx/access.log
--http-client-body-temp-path=/home/nginx/body-temp-path
--http-proxy-temp-path=/home/nginx/proxy-temp-path
--http-fastcgi-temp-path=/home/nginx/fastcgi-temp-path
--http-uwsgi-temp-path=/home/nginx/uwsgi-temp-path
--with-http_stub_status_module --with-mail --with-imap
--with-imap_ssl_module --with-mail_ssl_module --with-http_ssl_module
--with-http_perl_module --with-http_flv_module
--with-http_realip_module --with-http_dav_module
--with-http_sub_module --with-http_addition_module
--with-http_gzip_static_module --with-http_secure_link_module
--with-http_random_index_module --with-http_geoip_module
--with-http_mp4_module --with-debug --user=nginx --group=nginx
--with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic'

Description

После обновления с 1.1.17 до 1.1.19 началось вот такое:

wget 'http://127.0.0.1/file/01/20/100116794542020120.jpg' -O /dev/null -t 1
--2012-04-17 02:04:07-- http://127.0.0.1/file/01/20/100116794542020120.jpg
Устанавливается соединение с 127.0.0.1:80... соединение установлено.
Запрос HTTP послан, ожидается ответ... Не получено никаких данных.
Завершение.

Firefox на запросы файла говорит, что соединение сброшено.

(nginx запущен в openvz-контейнере, ставился из пакета
http://yum.aclub.net/pub/linux/centos/5/umask/x86_64/nginx-1.1.19-umask.9.x86_64.rpm
).

Без дебага в логе примерно вот такое после каждого запроса:

2012/04/17 02:04:09 [notice] 27710#0: signal 17 (SIGCHLD) received
2012/04/17 02:04:09 [notice] 27710#0: signal 29 (SIGIO) received

Attachments (1)

nginx_bug.tar.gz (3.6 KB ) - added by openid.yandex.ru/umask 9 years ago.
-----------------------------10000886252107727830518365382 Content-Disposition: form-data; name="replace" on

Download all attachments as: .zip

Change History (3)

by openid.yandex.ru/umask, 9 years ago

Attachment: nginx_bug.tar.gz added

Content-Disposition: form-data; name="replace"

on

comment:1 by openid.yandex.ru/umask, 9 years ago

в аттаче конфиг и дебаг лог.

если нужно - могу дать доступ к клонированному контейнеру openvz.

comment:2 by Maxim Dounin, 9 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #152, the r4601 fixes this.

Note: See TracTickets for help on using tickets.