Opened 2 years ago

Closed 2 years ago

#1575 closed defect (duplicate)

use "font/woff" and "font/woff2" in file "mime.types"

Reported by: david.sardari@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.15.x
Keywords: Cc:
uname -a: Linux mio-webserver 4.14.49-gentoo #1 SMP Tue Jun 12 18:47:16 CEST 2018 x86_64 Intel(R) Xeon(R) CPU @ 2.20GHz GenuineIntel GNU/Linux
nginx -V: nginx version: nginx/1.15.0
configure arguments: --prefix=/usr --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error_log --pid-path=/run/nginx.pid --lock-path=/run/lock/nginx.lock --with-cc-opt='-I/usr/include -DNGX_HAVE_INET6=0' --with-ld-opt=-L/usr/lib64 --http-log-path=/var/log/nginx/access_log --http-client-body-temp-path=/var/lib/nginx/tmp/client --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --with-compat --with-threads --without-http_auth_basic_module --without-http_autoindex_module --without-http_browser_module --without-http_empty_gif_module --without-http_fastcgi_module --without-http_geo_module --without-http_grpc_module --without-http_gzip_module --without-http_limit_req_module --without-http_limit_conn_module --without-http_memcached_module --without-http_mirror_module --without-http_proxy_module --without-http_referer_module --without-http_scgi_module --without-http_ssi_module --without-http_split_clients_module --without-http_upstream_hash_module --without-http_upstream_ip_hash_module --without-http_upstream_keepalive_module --without-http_upstream_least_conn_module --without-http_upstream_zone_module --without-http_userid_module --without-http_uwsgi_module --with-http_gzip_static_module --add-module=external_module/headers-more-nginx-module-0.33 --add-module=external_module/ngx_slowfs_cache-1.10 --add-module=external_module/ngx_brotli-37ab9b2933a0b756ba3447000b7f31d432ed8228 --without-http-cache --without-stream_access_module --without-stream_geo_module --without-stream_limit_conn_module --without-stream_map_module --without-stream_return_module --without-stream_split_clients_module --without-stream_upstream_hash_module --without-stream_upstream_least_conn_module --without-stream_upstream_zone_module --without-mail_imap_module --without-mail_pop3_module --without-mail_smtp_module --user=nginx --group=nginx

Description

The content type for .woff files is specified as "application/font-woff" in "/etc/nginx/mime.types". This is deprecated as stated in RFC 8081:

"Deprecated Alias: The existing registration "application/font-woff" is deprecated in favor of "font/woff"."

Thus, I replace in my configs...

application/font-woff woff;

with...

font/woff woff;
font/woff2 woff2;

IMHO, this should be the default.

Change History (1)

comment:1 by Maxim Dounin, 2 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1243.

Note: See TracTickets for help on using tickets.