Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#1578 closed defect (invalid)

Используется HTTP/2 даже есть нет http2 в listen

Reported by: adamant-z@… Owned by:
Priority: minor Milestone:
Component: nginx-module Version: 1.14.x
Keywords: http2 Cc: demidov@…
uname -a: Linux cs18065 2.6.32-504.1.3.el6.x86_64 #1 SMP Tue Nov 11 17:57:25 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.14.0
built by gcc 4.4.7 20120313 (Red Hat 4.4.7-18) (GCC)
built with OpenSSL 1.0.2o 27 Mar 2018
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --with-compat --modules-path=/usr/lib64/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --without-mail_smtp_module --without-mail_imap_module --without-mail_pop3_module --with-http_ssl_module --with-openssl=/builddir/build/BUILD/bx-nginx-1.14.0/openssl-1.0.2o --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-http_auth_request_module --with-http_geoip_module=dynamic --add-module=/builddir/build/BUILD/bx-nginx-1.14.0/ngx_devel_kit-0.3.0 --add-module=/builddir/build/BUILD/bx-nginx-1.14.0/ngx_http_set_hash-master --add-module=/builddir/build/BUILD/bx-nginx-1.14.0/lua-nginx-module-0.10.9rc5 --add-module=/builddir/build/BUILD/bx-nginx-1.14.0/ngx_mod_zip-1.1.6 --add-module=/builddir/build/BUILD/bx-nginx-1.14.0/nginx-push-stream-module-0.4.1 --add-module=/builddir/build/BUILD/bx-nginx-1.14.0/headers-more-nginx-module --add-module=/builddir/build/BUILD/bx-nginx-1.14.0/naxsi_src --with-threads --with-stream --with-stream_ssl_module --with-http_slice_module --with-file-aio --with-ipv6 --with-http_v2_module --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic'

Description

Если в конфигурации есть несколько секций server, и хотя бы в одной из них в listen указано ssl http2, то и для других секций с SSL используется HTTP/2.0 для клиентов, даже если в них не указано http2.

А по умолчанию такое поведение не ожидается.

Change History (2)

comment:1 by Valentin V. Bartenev, 2 years ago

Resolution: invalid
Status: newclosed

Так и должно быть. Протокол может быть включен только на весь порт целиком. Если несколько блоков server разделяют один и тот же порт, то по HTTP/2 будут доступны все.

Цитата из документации:

Параметр http2 (1.9.5) позволяет принимать на этом порту HTTP/2-соединения.

http://nginx.org/ru/docs/http/ngx_http_core_module.html#listen

comment:2 by Ruslan Ermilov, 2 years ago

Duplicate of #846.

Note: See TracTickets for help on using tickets.