#1609 closed defect (invalid)

I cannot configure php7.2 on the latest version of nginx

Reported by: wowanus1@… Owned by:
Priority: minor Milestone:
Component: other Version: 1.14.x
Keywords: Cc:
uname -a: Linux steap.ru 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u2 (2017-06-26) x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.14.0 built by gcc 6.3.0 20170516 (Debian 6.3.0-18+deb9u1) built with OpenSSL 1.1.0f 25 May 2017 TLS SNI support enabled configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-g -O2 -fdebug-prefix-map=/data/builder/debuild/nginx-1.14.0/debian/debuild-base/nginx-1.14.0=. -specs=/usr/share/dpkg/no-pie-compile.specs -fstack-protector-strong -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fPIC' --with-ld-opt='-specs=/usr/share/dpkg/no-pie-link.specs -Wl,-z,relro -Wl,-z,now -Wl,--as-needed -pie'

Description

I could not understand why nginx always returns the error "An error occurred" (status 502) and thought the problem is in php.

Decided to reinstall Debian 9.1 and first of all to install php7.2, then I installed nginx 1.10.3 from the debian repository, in the location tab I specified the path to the php socket. After restarting nginx php pages began to run without errors.

Then I uninstalled completely nginx and installed a new version according to this instruction - https://my2i.ru/article/ustanovka-poslednej-versii-nginx-v-debian-8 in the location tab, I also specified the path to the socket, but when you open a php page in the browser again began to appear the error "An error occurred".

Here is the config that was used in nginx 1.10.3 and that is used in nginx 1.14.0. How do I resolve this error? P.S. there is practically no experience with Linux.

NGINX 1.10.3
location ~ \.php$ {

include snippets/fastcgi-php.conf;

# # With php-fpm (or other unix sockets):

fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;

}

NGINX 1.14.0
location ~ \.php$ {

root html;
fastcgi-pass unix:/var/run/php/php7.2-fpm.sock;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME /scripts$fastcgi_script_name;
include fastcgi_params;

}

Change History (1)

comment:1 Changed 14 months ago by mdounin

  • Resolution set to invalid
  • Status changed from new to closed

For questions on how to configure nginx, please consider using the support options available.

Note: See TracTickets for help on using tickets.