Opened 7 months ago

Closed 6 months ago

#1757 closed defect (invalid)

nginx segfault libc-2.24.so

Reported by: sandrodaquino.le@… Owned by:
Priority: minor Milestone:
Component: other Version: 1.15.x
Keywords: nginx segfault libc-2.24.so Cc:
uname -a: Linux mx 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3 (2019-02-02) x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.15.10 built by gcc 6.3.0 20170516 (Debian 6.3.0-18+deb9u1) built with OpenSSL 1.0.2r 26 Feb 2019 TLS SNI support enabled configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-g -O2 -fdebug-prefix-map=/data/builder/debuild/nginx-1.15.10/debian/debuild-base/nginx-1.15.10=. -specs=/usr/share/dpkg/no-pie-compile.specs -fstack-protector-strong -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fPIC' --with-ld-opt='-specs=/usr/share/dpkg/no-pie-link.specs -Wl,-z,relro -Wl,-z,now -Wl,--as-needed -pie' --add-dynamic-module=/usr/src/username/incubator-pagespeed-ngx-1.13.35.2-stable --add-dynamic-module=/usr/src/username/ModSecurity-nginx --add-dynamic-module=/usr/src/username/ngx_cache_purge-2.3

Description

Hi, occasionally (6-7 times at day) on my vps i have this error:

Mar 29 23:06:29 mx kernel: [3446677.813287] nginx[5620]: segfault at 0 ip 00007f15e3fb9676 sp 00007ffd5f1bcb88 error 4 in libc-2.24.so[7f15e3f39000+195000]
Mar 30 11:54:30 mx kernel: [3492759.404034] nginx[31680]: segfault at 0 ip 00007f15e3fb9676 sp 00007ffd5f1bccd8 error 4 in libc-2.24.so[7f15e3f39000+195000]
Mar 30 13:32:01 mx kernel: [3498610.481672] nginx[23957]: segfault at 0 ip 00007f15e3fb9676 sp 00007ffd5f1bccd8 error 4 in libc-2.24.so[7f15e3f39000+195000]

Change History (5)

comment:1 Changed 7 months ago by i.bakirov@…

You are using ModSecurity? and maybe https://github.com/SpiderLabs/ModSecurity-nginx/issues/136 this is the same as yours

comment:2 Changed 7 months ago by mdounin

Your "nginx -V" output suggests you are using various 3rd party modules. Are you able to reproduce the problem without 3rd party modules?

comment:3 Changed 7 months ago by sandrodaquino.le@…

@i.bakirov@…: yes, i have ModSecurity? 3.0.3, and seems to be the same bug mentioned at https://github.com/SpiderLabs/ModSecurity-nginx/issues/136

@mdounin: i'll try to disable one by one 3rd party modules an track the logs

If you need other info about my system give me the command to paste into my prompt

Thank you all

comment:4 Changed 6 months ago by sandrodaquino.le@…

ok, no error with modsecurity off

comment:5 Changed 6 months ago by mdounin

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for checking, closing this.

Note: See TracTickets for help on using tickets.