Opened 3 weeks ago

Closed 3 weeks ago

#1778 closed enhancement (duplicate)

Implement "SSLOpenSSLConfCmd" equivalent

Reported by: hardfalcon@… Owned by:
Priority: minor Milestone:
Component: nginx-module Version:
Keywords: ngx_http_ssl_module ngx_mail_ssl_module ngx_stream_ssl_module Cc:
uname -a: Linux xxx 5.0.11.a-1-hardened #1 SMP PREEMPT Fri May 3 00:49:11 CEST 2019 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.16.0 built with OpenSSL 1.1.1b 26 Feb 2019 TLS SNI support enabled configure arguments: --prefix=/etc/nginx --conf-path=/etc/nginx/nginx.conf --sbin-path=/usr/bin/nginx --pid-path=/run/nginx.pid --lock-path=/run/lock/nginx.lock --user=http --group=http --http-log-path=/var/log/nginx/access.log --error-log-path=stderr --http-client-body-temp-path=/var/lib/nginx/client-body --http-proxy-temp-path=/var/lib/nginx/proxy --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --with-cc-opt='-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2' --with-ld-opt=-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now --with-compat --with-debug --with-file-aio --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_degradation_module --with-http_flv_module --with-http_geoip_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-pcre-jit --with-stream --with-stream_geoip_module --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-threads

Description

Please offer an equivalent to Apache mod_ssl's "SSLOpenSSLConfCmd" configuration directive, in order to allow users direct access to OpenSSL's SSL_CONF_cmd function:

https://www.openssl.org/docs/man1.1.1/man3/SSL_CONF_cmd.html

OpenSSL keeps adding new features which can be configured through this very simple API, and it's frustrating having to hope and wait if the nginx developers will deem a new feature important enough to allocate it a dedicated configuration directive name every single time.

One current use case I have would be the "PrioritizeChaCha?" option, but I could also imagine use cases for some other parameters ("RecordPadding?" for example).

Personally, I'd even prefer to be able to do the whole SSL configuration by just directly using SSL_CONF_cmd directly instead of having to look up what keywords nginx (or Apache) use for whatever parameters I want to configure.

I imagine this would also make life easier for people using LTS Linux distros (for example, Ubuntu 18.04 has recently gotten an OpenSSL 1.1.1 backport added to its "bionic-proposed" repo, but users will not be able to disable TLSv1.3 in case of problems because the nginx package was built using OpenSSL 1.1.0).

Change History (1)

comment:1 Changed 3 weeks ago by mdounin

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1445.

Note: See TracTickets for help on using tickets.