Opened 8 years ago

Closed 8 years ago

#18 closed defect (fixed)

RHEL Package repo issue

Reported by: www.google.com/accounts/o8/id?id=AItOawlUZ8IjYc_77WfCCetRoo8hsIR6raOfR7I Owned by: somebody
Priority: blocker Milestone:
Component: nginx-package Version: 1.0.x
Keywords: RHEL repo Cc: visseraj@…
uname -a: Linux test.justapinch.com 2.6.18-194.17.4.el5 #1 SMP Wed Oct 20 13:03:08 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx: nginx version: nginx/1.0.6 nginx: built by gcc 4.1.2 20080704 (Red Hat 4.1.2-50) nginx: TLS SNI support disabled nginx: configure arguments: --prefix=/etc/nginx/ --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwcgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-mail --with-mail_ssl_module --with-file-aio --with-ipv6

Description

I just tried to use the RHEL repo to install nginx and got the following error:

http://nginx.org/packages/rhel/5Server/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: nginx. Please verify its path and try again

The '5Server' part of the path is wrong. I changed my repo to the following at it works.

[nginx]
name=nginx repo
baseurl=http://nginx.org/packages/rhel/5/$basearch/
gpgcheck=0
enabled=1

Change History (3)

comment:1 Changed 8 years ago by fabler

How do you add nginx repository first time? Is there any rhel specific tool for it?

Not a bug actually cause besides 5Server there is 5Client, and for RHEL6 there are 6Client, 6Server, 6ComputeNode, 6Workstation, and it is senseless to create these directories in our repo with same content, but I can change my opinion, if directory names hardcoded somewhere in rhel.

comment:2 Changed 8 years ago by www.google.com/accounts/o8/id?id=AItOawlrBgFmdbPtP7F_oAoxHZRcEzizzkclPEc

You can trivially cover the whole range for RHEL editions and clones by creating symlinks for each $releasever that in fact point to the correct directory.

See here:

http://people.fedoraproject.org/~tmz/repo/puppet/epel/

Reference list:

http://ftp.redhat.com/pub/redhat/linux/enterprise/

comment:3 Changed 8 years ago by fabler

  • Resolution set to fixed
  • Status changed from new to closed

As far as I can see the root cause is $releasever from yum config substituted differently depending on RHEL edition.
So unambiguous instructions were added to the site, and nginx-release rpm packages (with a nginx.repo config file for yum and a signing key) were uploaded.

Note: See TracTickets for help on using tickets.