Opened 3 weeks ago

Closed 3 weeks ago

#1826 closed defect (fixed)

Gzip deflate broken in some cases

Reported by: g.krist.linqhost.nl@… Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.17.x
Keywords: gzip deflate Cc:
uname -a: Linux xxxxxxxxx 3.10.0-957.12.2.el7.x86_64 #1 SMP Fri Apr 19 21:09:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx/1.17.2

Description

In the 1.17 branch some particular gzipped request fail with the following error:

 zero size buf in writer t:1 r:1 f:0 0000000001D9FBB0 0000000001D9FBB0-0000000001D9FBB0 0000000000000000 0-0 while sending response to client,

After a quick look I think the problem is in ngx_http_gzip_filter_module.c after ctx->out_buf->last = ctx->zstream.next_out;

I added an example of a .js file. If you request it, you will get an connection error.

Attachments (1)

spin.js (10.0 KB) - added by g.krist.linqhost.nl@… 3 weeks ago.
Example file to trigger connection

Download all attachments as: .zip

Change History (2)

Changed 3 weeks ago by g.krist.linqhost.nl@…

Example file to trigger connection

comment:1 Changed 3 weeks ago by mdounin

  • Resolution set to fixed
  • Status changed from new to closed

This was already reported here:

http://mailman.nginx.org/pipermail/nginx-devel/2019-July/012469.html

Fix is already committed (0ef2bc0ec9c9) and will be available in the next release.

Note: See TracTickets for help on using tickets.