Opened 4 weeks ago

Closed 3 weeks ago

#1839 closed defect (duplicate)

Add new config/option for OpenSSL 1.1.1 / TLS 1.3

Reported by: mvorisek@… Owned by:
Priority: major Milestone: nginx-1.17
Component: other Version: 1.17.x
Keywords: tls13 openssl Cc:
uname -a: Linux debian 4.19.0-5-amd64
nginx -V: nginx version: nginx/1.14.2 built with OpenSSL 1.1.1c 28 May 2019

Description

see https://github.com/openssl/openssl/issues/9690

Starting with OpenSSL 1.1.1 with TLS 1.3 support there was a new ciphersuites option introduced - see https://www.openssl.org/docs/man1.1.1/man3/SSL_CTX_set_cipher_list.html . Now there are two options - cipher list for TLS 1.2 and below and cipher suites for TLS 1.3.

This new cipher suites option needs to be supported by nginx, i.e. new option has to be introduced.

Change History (1)

comment:1 Changed 3 weeks ago by pluknet

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1529.

Note: See TracTickets for help on using tickets.