Opened 9 years ago

Closed 9 years ago

#190 closed defect (fixed)

Error 337 (net::ERR_SPDY_PROTOCOL_ERROR) (spdy-48 and nginx 1.3.3)

Reported by: Lowshadow . Owned by: Valentin V. Bartenev
Priority: minor Milestone:
Component: other Version: 1.3.x
Keywords: SPDY Cc:
uname -a: Linux hostname.localhost 2.6.32-042stab053.5 #1 SMP Tue Mar 27 11:42:17 MSD 2012 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.3.3
built by gcc 4.4.6 20120305 (Red Hat 4.4.6-4) (GCC)
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx/ --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_stub_status_module --with-mail --with-mail_ssl_module --with-file-aio --with-ipv6 --with-cc-opt='-O2 -g'

Description

Short description

Nginx 1.3.3 patched with latest SPDY patch (patch.spdy-48) breaks connection with browser throwing Error 337 (net::ERR_SPDY_PROTOCOL_ERROR): Unknown error. in Google Chrome (0.0.1132.57) and breaking web site links in Mozilla Firefox (14.0.1).

Server configuration

We have Nginx configured to pass requests to php-fpm process socket via fastcgi_pass. Server is listening on 443 with spdy enabled:

listen 443 spdy;

Some basic debugging

When browser throws an error, nothing occurs in nginx error log.
I am attaching debug log from chrome://net-internals/#spdy when this error occurs.

Reproduce in Google Chrome

With several fast F5 hits, or link clicks, Chrome will throw Error 337 (net::ERR_SPDY_PROTOCOL_ERROR): Unknown error and make site unusable under SSL for several minutes (while spdy connection is active). Restarting browser will fix the problem.

Reproduce in Mozilla FireFox

Same like with Google Chrome except FireFox won't throw an error but will make site unusable under SSL. For example, clicking on any link will just reload the current page or do nothing.

Personal thoughts

I have browsed the web looking for any information about this and all I could find is:

https://github.com/netty/netty/issues/442#issuecomment-6868517

where people state that this is caused by a race condition. Also, I think that this error is fixed in SPDY protocol v3 because Google had same problem with there services back when they were using v2.

Attachments (1)

spdy_chrome_debug_log.txt (39.6 KB ) - added by Lowshadow . 9 years ago.
debug of a spdy session using chrome://net-internals/#spdy

Download all attachments as: .zip

Change History (4)

by Lowshadow ., 9 years ago

Attachment: spdy_chrome_debug_log.txt added

debug of a spdy session using chrome://net-internals/#spdy

comment:1 by Valentin V. Bartenev, 9 years ago

Owner: changed from somebody to Valentin V. Bartenev
Status: newassigned

Thanks for reporting the bug. Please try the new patch:
http://nginx.org/patches/spdy/patch.spdy-49.txt (for nginx 1.3.4)

Last edited 9 years ago by Valentin V. Bartenev (previous) (diff)

comment:2 by Lowshadow ., 9 years ago

I can confirm that patch fixes this bug on Nginx 1.3.4. Best regards.

comment:3 by Valentin V. Bartenev, 9 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.