Opened 7 months ago

Closed 7 months ago

#1903 closed defect (invalid)

Debian package dependencies are broken

Reported by: robbieh@… Owned by:
Priority: minor Milestone:
Component: nginx-package Version: 1.14.x
Keywords: Cc:
uname -a: Linux pimento 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2 (2019-08-28) x86_64 GNU/Linux
nginx -V: can't install, so can't run this

Description

nginx-extras is uninstallable from the Debian repo.

Full output from apt install is below. You can also find a question at SuperUser here: https://superuser.com/questions/1457545/nginx-extras-installation-on-debian-8

The sources.list contains:

deb http://nginx.org/packages/debian/ buster nginx
deb-src http://nginx.org/packages/debian/ buster nginx


> sudo apt install nginx nginx-extras
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nginx-extras : Depends: libnginx-mod-http-auth-pam (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-cache-purge (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-dav-ext (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-echo (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-fancyindex (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-geoip (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-headers-more-filter (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-image-filter (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-lua (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-perl (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-subs-filter (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-uploadprogress (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-upstream-fair (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-http-xslt-filter (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-mail (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-nchan (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: libnginx-mod-stream (= 1.14.2-2+deb10u1) but it is not going to be installed
                Depends: nginx-common (= 1.14.2-2+deb10u1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Change History (1)

comment:1 by thresh, 7 months ago

Resolution: invalid
Status: newclosed

Thank you for you report.

You're trying to install two conflicting packages:

  • nginx, which will be installed from nginx.org repositories as version provided is higher than what is shipped in Buster
  • nginx-extras, which will be installed from Debian's own repositories

This cant work - you need to choose either. If you need -extras functionality, the only way is to disable nginx.org repos as we dont provide such a package.

The full list of packages we ship is as follows:

nginx
nginx-dbg
nginx-module-geoip
nginx-module-geoip-dbg
nginx-module-image-filter
nginx-module-image-filter-dbg
nginx-module-njs
nginx-module-njs-dbg
nginx-module-perl
nginx-module-perl-dbg
nginx-module-xslt
nginx-module-xslt-dbg

Note: See TracTickets for help on using tickets.