#1915 closed defect (duplicate)

Potential Memory Leak in directory 'src/event'. file 'ngx_event_openssl_stapling.c'

Reported by: wp02855@… Owned by:
Priority: minor Milestone:
Component: other Version: 1.15.x
Keywords: Cc:
uname -a: bill@foobar 4.4.0-18362-Microsoft #476-Microsoft Fri Nov 01 16:53:00 PST 2019 x86_64 GNU/Linux
nginx -V: nginx -V: version 1.15.0 (using static analysis of source code)

Description

In reviewing source code in nginx-1.15.0, it would appear that there are some memory leaks in file 'ngx_event_openssl_stapling.c' which when functions in this file are called, the memory allocations are not released, leading to over-utilization of memory over time, the patch file is below:

--- ngx_event_openssl_stapling.c.orig 2019-12-12 12:26:12.953983500 -0800
+++ ngx_event_openssl_stapling.c 2019-12-12 12:33:11.915116800 -0800
@@ -838,6 +838,7 @@

log = ngx_palloc(pool, sizeof(ngx_log_t));
if (log == NULL) {

+ ngx_pfree(ctx); /* release memory allocated to ctx */

ngx_destroy_pool(pool);
return NULL;

}

Attachments (1)

ngx_event_openssl_stapling.c.patch (356 bytes ) - added by wp02855@… 11 months ago.
patch file for bug reported in ticket 1915

Download all attachments as: .zip

Change History (2)

by wp02855@…, 11 months ago

patch file for bug reported in ticket 1915

comment:1 by Maxim Dounin, 11 months ago

Resolution: duplicate
Status: newclosed

Duplicate of #1914.

Note: See TracTickets for help on using tickets.