Opened 7 months ago

Closed 7 months ago

#1952 closed defect (duplicate)

systemd[1]: nginx.service: Failed to parse PID from file /run/nginx.pid: Invalid argument

Reported by: equaeghe@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.16.x
Keywords: Cc: equaeghe@…
uname -a: Linux equaeghe 5.4.28-gentoo #3 SMP Fri Apr 3 16:48:18 CEST 2020 x86_64 QEMU Virtual CPU version (cpu64-rhel6) GenuineIntel GNU/Linux
nginx -V: nginx version: nginx/1.16.1
built with OpenSSL 1.1.1d 10 Sep 2019 (running with OpenSSL 1.1.1f 31 Mar 2020)
TLS SNI support enabled
configure arguments: --prefix=/usr --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error_log --pid-path=/run/nginx.pid --lock-path=/run/lock/nginx.lock --with-cc-opt=-I/usr/include --with-ld-opt=-L/usr/lib64 --http-log-path=/var/log/nginx/access_log --http-client-body-temp-path=/var/lib/nginx/tmp/client --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --with-compat --with-http_v2_module --with-pcre --with-http_realip_module --with-http_ssl_module --without-stream_access_module --without-stream_geo_module --without-stream_limit_conn_module --without-stream_map_module --without-stream_return_module --without-stream_split_clients_module --without-stream_upstream_hash_module --without-stream_upstream_least_conn_module --without-stream_upstream_zone_module --without-mail_imap_module --without-mail_pop3_module --without-mail_smtp_module --user=nginx --group=nginx

Description

There is a known (harmless?) race condition when systemd starts nginx on 1-CPU systems. It exhibits itself with the following message logged during nginx startup:

systemd[1]: nginx.service: Failed to parse PID from file /run/nginx.pid: Invalid argument

Suggested fixes can be found:

https://bugs.launchpad.net/ubuntu/+source/nginx/+bug/1581864

In particular, there is a patch (used by Ubuntu):

https://launchpadlibrarian.net/426320897/nginx-fix-pidfile.8.patch

It would be nice if this were upstreamed, so that everybody can get the fix.

Change History (1)

comment:1 by Maxim Dounin, 7 months ago

Resolution: duplicate
Status: newclosed

Duplicate of #1897.

Note: See TracTickets for help on using tickets.