Opened 4 weeks ago

Closed 4 weeks ago

#1970 closed defect (duplicate)

ssl_ecdh_curve avoid 0-RTT

Reported by: long76@… Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.17.x
Keywords: tls1.3 0-rtt ssl_ecdh_curve Cc: long76@…
uname -a:
nginx -V: nginx version: nginx/1.17.10
built by cl 16.00.40219.01 for 80x86
built with OpenSSL 1.1.1f 31 Mar 2020
TLS SNI support enabled
configure arguments: --with-cc=cl --builddir=objs.msvc8 --with-debug --prefix= -
-conf-path=conf/nginx.conf --pid-path=logs/nginx.pid --http-log-path=logs/access
.log --error-log-path=logs/error.log --sbin-path=nginx.exe --http-client-body-te
mp-path=temp/client_body_temp --http-proxy-temp-path=temp/proxy_temp --http-fast
cgi-temp-path=temp/fastcgi_temp --http-scgi-temp-path=temp/scgi_temp --http-uwsg
i-temp-path=temp/uwsgi_temp --with-cc-opt=-DFD_SETSIZE=1024 --with-pcre=objs.msv
c8/lib/pcre-8.44 --with-zlib=objs.msvc8/lib/zlib-1.2.11 --with-http_v2_module --
with-http_realip_module --with-http_addition_module --with-http_sub_module --wit
h-http_dav_module --with-http_stub_status_module --with-http_flv_module --with-h
ttp_mp4_module --with-http_gunzip_module --with-http_gzip_static_module --with-h
ttp_auth_request_module --with-http_random_index_module --with-http_secure_link_
module --with-http_slice_module --with-mail --with-stream --with-openssl=objs.ms
vc8/lib/openssl-1.1.1f --with-openssl-opt='no-asm no-tests -D_WIN32_WINNT=0x0501
' --with-http_ssl_module --with-mail_ssl_module --with-stream_ssl_module

Description

if i set ssl_ecdh_curve secp521r1:secp384r1; ssllabs show 0-RTT No
if i comment ssl_ecdh_curve secp521r1:secp384r1; ssllabs show 0-RTT Yes

why? what's different?

Change History (1)

comment:1 by Maxim Dounin, 4 weeks ago

Resolution: duplicate
Status: newclosed

Duplicate of #1969.

Note: See TracTickets for help on using tickets.