Opened 3 weeks ago

Closed 3 weeks ago

#1979 closed defect (duplicate)

listen 80 http2; combined with proxy_pass http:// brakes website

Reported by: Hans-Cees Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.19.x
Keywords: http2 proxy_pass Cc:
uname -a: 4.19.0-8-amd64 #1 SMP Debian 4.19.98-1 (2020-01-26) x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.18.0
built by gcc 9.2.0 (Alpine 9.2.0)
built with OpenSSL 1.1.1d 10 Sep 2019 (running with OpenSSL 1.1.1g 21 Apr 2020)
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --with-perl_modules_path=/usr/lib/perl5/vendor_perl --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-Os -fomit-frame-pointer' --with-ld-opt=-Wl,--as-needed

Description

Hi,

I do not know if this is how nginx should behave, but it surprised me and caused some searching.

when using
listen 80 http2;

together with nginx as reverse-proxy nginx did not connect to the proxied-site, and answered with files my browser tried to download, since no mime type was known.

Perhaps port 80 http2 should not be accepted as a valid config?

I am running nginx with docker on a debian vm.
image: nginx:stable-alpine



Attachments (1)

guth-nginx.txt (3.0 KB ) - added by Hans-Cees 3 weeks ago.
config

Download all attachments as: .zip

Change History (3)

by Hans-Cees, 3 weeks ago

Attachment: guth-nginx.txt added

config

comment:1 by Hans-Cees, 3 weeks ago

thank you for your wonderful server and hope I am not wasting your time.

comment:2 by Maxim Dounin, 3 weeks ago

Resolution: duplicate
Status: newclosed

Using listen ... http2; without ssl configures listening socket to use HTTP/2 with prior knowledge. Browsers are not able to talk via sockets configured this way. Duplicate of #808.

Note: See TracTickets for help on using tickets.