Opened 3 months ago

Closed 3 months ago

#2007 closed defect (duplicate)

HTTP2 directive from one "server" passed to another

Reported by: pupkur@… Owned by:
Priority: minor Milestone:
Component: documentation Version: 1.16.x
Keywords: Cc:
uname -a: Linux nginx 3.10.0-1062.4.1.el7.x86_64 #1 SMP Fri Oct 18 17:15:30 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.16.1

Description

Linux 3.10.0-1062.4.1.el7.x86_64 #1 SMP x86_64 GNU/Linux

nginx.conf

http {
    ...
    include a.conf
    include b.conf
    ...
}

a.conf

server {
    listen 443 ssl;
    server_name a.com;
    ...
}

b.conf

server {
    listen 443 ssl http2;
    server_name b.com;
    ...
}

Expected result:

a.com HTTP1.1
b.com HTTP2

Actual result:

a.com HTTP2
b.com HTTP2

Change History (2)

comment:1 by pupkur@…, 3 months ago

Please change component

comment:2 by Maxim Dounin, 3 months ago

Resolution: duplicate
Status: newclosed

Duplicate of #1623.

Note: See TracTickets for help on using tickets.