Opened 5 weeks ago

Closed 5 weeks ago

#2070 closed defect (duplicate)

nginx build_module can't build headers more or shibboleth modules

Reported by: jonikorhonen@… Owned by: Andrei Belov
Priority: minor Milestone:
Component: nginx-package Version: 1.18.x
Keywords: Cc:
uname -a: Linux b7634d44df2d 5.9.1-arch1-1 #1 SMP PREEMPT Sat, 17 Oct 2020 13:30:37 +0000 x86_64 GNU/Linux (Debian Buster running in docker container)
nginx -V: nginx version: nginx/1.18.0
built by gcc 8.3.0 (Debian 8.3.0-6)
built with OpenSSL 1.1.1d 10 Sep 2019
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-g -O2 -fdebug-prefix-map=/data/builder/debuild/nginx-1.18.0/debian/debuild-base/nginx-1.18.0=. -fstack-protector-strong -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fPIC' --with-ld-opt='-Wl,-z,relro -Wl,-z,now -Wl,--as-needed -pie'

Description

Running

build_module.sh --skip-depends -y -v 1.18.0 https://github.com/openresty/headers-more-nginx-module.git

for headers more results in

===> Generating nginx-module-headersmore.deb-changelog
make[1]: Entering directory '/root/debuild/nginx-1.18.0/docs'
make[1]: *** No rule to make target '/root/debuild/nginx-1.18.0/debian/nginx-module-headersmore.deb-changelog'.  Stop.
make[1]: Leaving directory '/root/debuild/nginx-1.18.0/docs'
make: *** [Makefile:156: nginx-module-headersmore.deb-changelog] Error 2
build_module.sh: ERROR: Build failed

And same for shibboleth

build_module.sh --skip-depends -y -v 1.18.0 https://github.com/nginx-shib/nginx-http-shibboleth.git

===> Generating nginx-module-shibboleth.deb-changelog
make[1]: Entering directory '/root/debuild/nginx-1.18.0/docs'
make[1]: *** No rule to make target '/root/debuild/nginx-1.18.0/debian/nginx-module-shibboleth.deb-changelog'.  Stop.
make[1]: Leaving directory '/root/debuild/nginx-1.18.0/docs'
make: *** [Makefile:156: nginx-module-shibboleth.deb-changelog] Error 2
build_module.sh: ERROR: Build failed

Change History (4)

comment:1 by Andrei Belov, 5 weeks ago

Component: documentationnginx-package
Owner: set to Andrei Belov
Status: newassigned

comment:2 by Andrei Belov, 5 weeks ago

Status: assignedaccepted

Make sure you're using the build_module.sh script from here:
http://hg.nginx.org/pkg-oss/file/default/build_module.sh

Also, please check #2067.

comment:3 by jonikorhonen@…, 5 weeks ago

Original problem seems to have been with using build_module.sh from https://hg.nginx.org/pkg-oss/archive/tip.tar.gz and changing that to default.tar.gz solved it, however now it fails at installing the built modules.

dpkg: dependency problems prevent configuration of nginx-module-headersmore:
 nginx-module-headersmore depends on nginx-r1.18.0; however:
  Package nginx-r1.18.0 is not installed.

dpkg: error processing package nginx-module-headersmore (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nginx-module-shibboleth:
 nginx-module-shibboleth depends on nginx-r1.18.0; however:
  Package nginx-r1.18.0 is not installed.

dpkg: error processing package nginx-module-shibboleth (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nginx-module-headersmore
 nginx-module-shibboleth

Nginx is installed as

wget -qO - https://nginx.org/keys/nginx_signing.key | apt-key add - 
echo "deb http://nginx.org/packages/debian/ buster nginx" > /etc/apt/sources.list.d/nginx.list
apt-get update && apt-get install nginx

Seems to be same(ish) problem in the end as with #2067.

in reply to:  3 comment:4 by Andrei Belov, 5 weeks ago

Resolution: duplicate
Status: acceptedclosed

Replying to jonikorhonen@…:

Seems to be same(ish) problem in the end as with #2067.

Yes, this is exactly the same one. I'm going to close this one as a duplicate of #2067, and provide the solution in #2067 shortly.

Appreciate your attention.

Note: See TracTickets for help on using tickets.