Opened 3 weeks ago

Closed 3 weeks ago

#2083 closed enhancement (duplicate)

The restriction on directive "fastcgi_buffers" is not complete.

Reported by: zhoushulin1992@… Owned by:
Priority: minor Milestone:
Component: documentation Version: 1.18.x
Keywords: Cc: zhoushulin1992@…
uname -a: Linux xlarge 4.15.0-72-generic #81-Ubuntu SMP Tue Nov 26 12:20:02 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.18.0
built by gcc 7.4.0 (Ubuntu 7.4.0-1ubuntu1~18.04.1)
configure arguments: --prefix=/usr/local/nginx --with-pcre=/root/Downloads/pcre-8.43

Description

Based on the handling logic in src/http/modules/ngx_http_fastcgi_module.c, the "fastcgi_buffers" must be at least 2 buffers, but the document doesn't mentioned it. It is better to add this information in the doc https://nginx.org/en/docs/http/ngx_http_fastcgi_module.html#fastcgi_buffers.

Change History (1)

comment:1 by Maxim Dounin, 3 weeks ago

Resolution: duplicate
Status: newclosed

Closing this as duplicate of #2084, which is more generic.

Note: See TracTickets for help on using tickets.