Opened 3 weeks ago

Closed 3 weeks ago

#2088 closed enhancement (duplicate)

The relationship between directive "uwsgi_busy_buffers_size" and other two directives is not recorded clearly.

Reported by: zhoushulin1992@… Owned by:
Priority: minor Milestone:
Component: documentation Version: 1.18.x
Keywords: Cc: zhoushulin1992@…
uname -a: Linux xlarge 4.15.0-72-generic #81-Ubuntu SMP Tue Nov 26 12:20:02 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.18.0
built by gcc 7.4.0 (Ubuntu 7.4.0-1ubuntu1~18.04.1)
configure arguments: --prefix=/usr/local/nginx --with-pcre=/root/Downloads/pcre-8.43

Description

In the document of directive "uwsgi_busy_buffers_size", it says that "By default, size is limited by the size of two buffers set by the uwsgi_buffer_size and uwsgi_buffers directives". Indeed, based on the handling logic in src/http/modules/ngx_http_uwsgi_module.c, the value of "uwsgi_busy_buffers_size" must be equal or greater than the maximum of the value of "uwsgi_buffer_size" and "uwsgi_buffers" size. So it is recommended to add this information in the doc of "uwsgi_busy_buffers_size"(https://nginx.org/en/docs/http/ngx_http_uwsgi_module.html#uwsgi_busy_buffers_size).

The same situation happens in directive "uwsgi_temp_file_write_size" in https://nginx.org/en/docs/http/ngx_http_uwsgi_module.html#uwsgi_temp_file_write_size, and directive "uwsgi_max_temp_file_size" in https://nginx.org/en/docs/http/ngx_http_uwsgi_module.html#uwsgi_max_temp_file_size. They should all be equal or greater than the maximum of the value of "uwsgi_buffer_size" and "uwsgi_buffers" size.

What's more, the value of directive "uwsgi_busy_buffers_size" must be less than (number-of-uwsgi_buffers - 1)*size-of-uwsgi_buffers. This also should be recorded.

Change History (2)

comment:1 by Maxim Dounin, 3 weeks ago

Closing this as duplicate of #2086, which is more generic, as applies to proxy.

comment:2 by Maxim Dounin, 3 weeks ago

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.