Opened 8 months ago

Closed 8 months ago

#2143 closed defect (duplicate)

openssl 3.0.0 compatible nginx version

Reported by: satya-rajesh@… Owned by:
Priority: critical Milestone: nginx-1.19.8
Component: nginx-package Version: 1.19.x
Keywords: Cc:
uname -a: linux photon
nginx -V: 1.19.3

Description (last modified by satya-rajesh@…)

While compiling observed that nginx is not compatible with openssl 3.0.0.

nginx is using deprecated APIs which are not present in openssl 3.0.0 (alpha).

Build status:
Failed due to ENGINE_*, HMAC_* APIs are deprecated

Please provide nginx release compatible to openssl 3.0.0.

Change History (2)

comment:1 by satya-rajesh@…, 8 months ago

Description: modified (diff)

comment:2 by Maxim Dounin, 8 months ago

Resolution: duplicate
Status: newclosed

Duplicate of #1964.

Note: See TracTickets for help on using tickets.