Opened 6 months ago

Closed 6 months ago

#2171 closed defect (duplicate)

Nginx causing missing body content data since v1.19.1

Reported by: breisig@… Owned by:
Priority: critical Milestone:
Component: nginx-core Version: 1.19.x
Keywords: Cc:
uname -a: Linux localdev.myserver.com 4.18.0-301.1.el8.x86_64 #1 SMP Tue Apr 13 16:24:22 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.20.0
built by gcc 8.4.1 20200928 (Red Hat 8.4.1-1) (GCC)
built with OpenSSL 1.1.1g FIPS 21 Apr 2020
TLS SNI support enabled
configure arguments: --prefix=/usr --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --pid-path=/run/nginx.pid --lock-path=/var/lib/ --http-log-path=/var/log/nginx/access.log --with-ipv6 --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_xslt_module --with-http_image_filter_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_gzip_static_module --with-http_random_index_module --with-http_secure_link_module --with-http_degradation_module --with-http_stub_status_module --without-mail_pop3_module --without-mail_imap_module --without-mail_smtp_module --without-http_autoindex_module --user=daemon --group=daemon --with-ld-opt=-ldl --http-fastcgi-temp-path=/tmp --with-http_v2_module --with-http_perl_module --with-cc-opt=-DTCP_FASTOPEN=23 --with-file-aio --add-module=./nginx-auth-ldap

Description

We are running puma + latest ruby on rails behind nginx (via proxy_pass). We have been running v1.18.0 and we recently upgraded to v1.20.0 and noticed nginx is causing missing characters. Like as if the buffer disconnects abit early.

Example. When I view the page source output using nginx v1.18.0, I see the *propery* output and the end of the stream.


<button name="button" type="button" title="Yes, I accept" class="button_base inverted no_wrap" id="btn_cookie">Yes, I accept</button>
</div>
</div>

</body>
</html>


But in v1.20.0, the page source is missing data.


<button name="button" type="button" title="Yes, I accept" class="button_base inverted no_wrap" id="btn_cookie">Yes, I accept</button>
</div>
</div>

</


It looks like the closing </body></html> tags are missing from the page. I have compiled nginx versions from 1.20.0 down to 1.19.0 and noticed that it started breaking in nginx 1.19.1. So something between 1.19.0 and 1.19.1 broke nginx. This is critical to fix.

Change History (1)

comment:1 by Maxim Dounin, 6 months ago

Resolution: duplicate
Status: newclosed

Duplicate of #2169.

Note: See TracTickets for help on using tickets.