Opened 7 years ago

Closed 7 years ago

#218 closed defect (invalid)

stable segfault on default Unbuntu binaries.

Reported by: avryabov.livejournal.com Owned by: somebody
Priority: major Milestone:
Component: nginx-core Version: 1.1.x
Keywords: Cc:
uname -a: Linux lom 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.1.19 TLS SNI support enabled configure arguments: --prefix=/etc/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-log-path=/var/log/nginx/access.log --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --lock-path=/var/lock/nginx.lock --pid-path=/var/run/nginx.pid --with-debug --with-http_addition_module --with-http_dav_module --with-http_geoip_module --with-http_gzip_static_module --with-http_image_filter_module --with-http_realip_module --with-http_stub_status_module --with-http_ssl_module --with-http_sub_module --with-http_xslt_module --with-ipv6 --with-sha1=/usr/include/openssl --with-md5=/usr/include/openssl --with-mail --with-mail_ssl_module --add-module=/build/buildd/nginx-1.1.19/debian/modules/nginx-auth-pam --add-module=/build/buildd/nginx-1.1.19/debian/modules/nginx-echo --add-module=/build/buildd/nginx-1.1.19/debian/modules/nginx-upstream-fair --add-module=/build/buildd/nginx-1.1.19/debian/modules/nginx-dav-ext-module

Description

# curl -i 'http://intuit4.intuit.ru/sites/default/files/css/css_882bd019fb4927fe990131533537db51.css' ; tail -4 /var/log/kern.log ; tail -4 /var/log/nginx/error.log
curl: (52) Empty reply from server
Sep 13 18:09:30 lom kernel: [ 1769.323819] nginx[5074]: segfault at 0 ip 00007f2fcf01c49b sp 00007fffa9f5ad28 error 6 in libc-2.15.so[7f2fceedc000+1b3000]
Sep 13 18:09:31 lom kernel: [ 1769.675542] nginx[5076]: segfault at 0 ip 00007f2fcf01c49b sp 00007fffa9f5ad28 error 6 in libc-2.15.so[7f2fceedc000+1b3000]
Sep 13 18:09:36 lom kernel: [ 1775.198850] nginx[5078]: segfault at 0 ip 00007f2fcf01c49b sp 00007fffa9f5ad28 error 6 in libc-2.15.so[7f2fceedc000+1b3000]
Sep 13 18:09:41 lom kernel: [ 1780.106366] nginx[5080]: segfault at 0 ip 00007f2fcf01c49b sp 00007fffa9f5ad28 error 6 in libc-2.15.so[7f2fceedc000+1b3000]
2012/09/13 18:09:31 [alert] 2189#0: worker process 5074 exited on signal 11 (core dumped)
2012/09/13 18:09:31 [alert] 2189#0: worker process 5076 exited on signal 11 (core dumped)
2012/09/13 18:09:36 [alert] 2189#0: worker process 5078 exited on signal 11 (core dumped)
2012/09/13 18:09:41 [alert] 2189#0: worker process 5080 exited on signal 11 (core dumped)

Change History (2)

comment:1 Changed 7 years ago by vbart

Please update your nginx first.
Nginx 1.1.19 is known as unstable.

Last edited 7 years ago by vbart (previous) (diff)

comment:2 Changed 7 years ago by mdounin

  • Resolution set to invalid
  • Status changed from new to closed

You have to upgrade to at least 1.2.0 (next version after 1.1.19) or apply this change manually.

Closing this as invalid as the issue is about Ubuntu package problem - it uses old version from 1.1.x development branch with the bug fixed long time ago. You should report the problem to the package maintainer instead, not here. BTW, it looks like they already have one.

Note: See TracTickets for help on using tickets.