Opened 16 months ago

Closed 3 months ago

#2196 closed enhancement (fixed)

resolver only ipv6 issue

Reported by: xqdoo00o@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.19.x
Keywords: resolver ipv6 Cc:
uname -a: 5.10.36-051036-generic #202105111331 SMP Tue May 11 13:34:33 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.20.1
built by gcc 9.3.0 (Ubuntu 9.3.0-10ubuntu2)
built with OpenSSL 1.1.1f 31 Mar 2020
TLS SNI support enabled

Description

Hi

Is there any solutions to only resolve AAAA record? now I could only find the ipv6=on/off option, but how could I only resolve for ipv6 address?
Perhaps there could be more multiple option like ipv6only ipv4only ipv6first ipv4first in resolver.


Change History (4)

comment:1 by Laurence 'GreenReaper' Parry, 9 months ago

This'd be helpful as a perhaps-more-obvious way to avoid #1330 - even though that suggests the issue is fixed, I kept getting warnings like OCSP responder timed out (110: Connection timed out) while requesting certificate status, responder: r3.o.lencr.org, peer: 23.54.21.155:80 every thirty minutes.

I hardcoded an IPv6 in /etc/hosts and stopped/restarted the server, but this obviously isn't ideal (and I don't think retrying a request via proxy_pass until it works is ideal, either).

My context: a free ARM64 Oracle Cloud VM where I'd used up two free IPv4 addresses they offer on the AMD64 VMs.

comment:2 by Maxim Dounin, 8 months ago

See also #1788.

comment:3 by Ruslan Ermilov <ru@…>, 3 months ago

In 8055:2a77754cd9fe/nginx:

The "ipv4=" parameter of the "resolver" directive.

When set to "off", only IPv6 addresses will be resolved, and no
A queries are ever sent (ticket #2196).

comment:4 by Sergey Kandaurov, 3 months ago

Resolution: fixed
Status: newclosed

Fix committed. We don't consider other options at this time.

Note: See TracTickets for help on using tickets.