Opened 8 days ago

Closed 7 days ago

#2415 closed defect (duplicate)

no error info showing when reload/test when same listen port with http is added in stream

Reported by: gentle-king@… Owned by:
Priority: minor Milestone:
Component: nginx-module Version: 1.21.x
Keywords: Cc: gentle-king@…
uname -a: Linux cent82-2c4g 4.18.0-348.7.1.el8_5.x86_64 #1 SMP Wed Dec 22 13:25:12 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.21.4
built by gcc 8.5.0 20210514 (Red Hat 8.5.0-4) (GCC)
built with OpenSSL 1.1.1o 3 May 2022
TLS SNI support enabled
configure arguments: --prefix=/home/ngx/nginx --with-cc-opt='-fstack-protector-all -fPIC -Wl,-z,relro,-z,now,-z,noexecstack' --http-client-body-temp-path=tmp/nginx_client_body --http-proxy-temp-path=tmp/nginx_proxy_temp --http-fastcgi-temp-path=tmp/nginx_fastcgi_temp --http-uwsgi-temp-path=tmp/uwsgi_temp --http-scgi-temp-path=tmp/scgi_temp --with-openssl=/home/ngx/build_ngx/openssl-1.1.1o --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_gzip_static_module --with-http_random_index_module --with-http_stub_status_module --with-pcre=/home/ngx/build_ngx/pcre-8.45 --with-zlib=/home/ngx/build_ngx/zlib-1.2.11 --with-stream

Description

step 1: config http listen 8020 and reload, it is success, below is http config:
http {

include mime.types;
default_type application/octet-stream;
log_format main '$remote_addr - $remote_user [$time_local] "$request" $status $body_bytes_sent "$http_referer" ';
access_log logs/access.log main;
keepalive_timeout 65;
server {

listen 8020;
server_name localhost;
location / {

root html;
index index.html index.htm;

}

}

}

step 2: add stream listen 8020 and do -t test, and reload; to find no error info is showing, and worker process is not yet refreshed.
stream {

server {

listen 8020;
proxy_pass www.google.com:80;

}

}
-t test and reload:
[ngx@cent82-2c4g sbin]$ ps -ef|grep nginx
ngx 1326958 1 0 00:34 ? 00:00:00 nginx: master process ./nginx
ngx 1326959 1326958 0 00:34 ? 00:00:00 nginx: worker process
ngx 1327006 1311702 0 00:47 pts/0 00:00:00 grep --color=auto nginx
[ngx@cent82-2c4g sbin]$ ./nginx -t
nginx: the configuration file /home/ngx/nginx/conf/nginx.conf syntax is ok
nginx: configuration file /home/ngx/nginx/conf/nginx.conf test is successful
[ngx@cent82-2c4g sbin]$ ./nginx -s reload
[ngx@cent82-2c4g sbin]$ ps -ef|grep nginx
ngx 1326958 1 0 00:34 ? 00:00:00 nginx: master process ./nginx
ngx 1326959 1326958 0 00:34 ? 00:00:00 nginx: worker process
ngx 1327039 1311702 0 00:47 pts/0 00:00:00 grep --color=auto nginx

Expect: show error info when do test or reload instead of show success.

Change History (1)

comment:1 by Maxim Dounin, 7 days ago

Resolution: duplicate
Status: newclosed

Duplicate of #1353.

Note: See TracTickets for help on using tickets.