Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#2428 closed enhancement (duplicate)

Suggestion: Windows 64-bit builds

Reported by: Herr-Sepp@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.23.x
Keywords: Cc:
uname -a:
nginx -V: 1.23

Description

Idea: Provide official Windows X64 binaries or update the build instructions.

I would appreciate it if in addition (or instead) of the Win32 X68 builds for Windows also X64 could be provided.

Background: Microsoft no longer supports 32bit applications in its nanoimages.
I found some older X64 Builds nginx-win on the internet and they work in the current nanoimages of windows server.

Change History (2)

comment:1 by Maxim Dounin, 15 months ago

Resolution: duplicate
Status: newclosed

Build instructions are available here.

The only tricky part is compiling OpenSSL for 64-bit if you need nginx with SSL compiled in, since nginx does not support automatic compiling of OpenSSL for Windows x64, and it needs to be compiled manually or with appropriate manual modifications of auto/lib/openssl/makefile.msvc (with VC-WIN32 target changed to VC-WIN64A).

Closing this as a duplicate of #1391.

comment:2 by Maxim Dounin, 15 months ago

Err, spent some more time looking into it, and have to correct myself: manual OpenSSL compilation is not needed as long as build instructions are followed, notably the --with-openssl-opt=no-asm option is used.

Note: See TracTickets for help on using tickets.