#2511 closed defect (duplicate)

try_files and $cookie_ problem

Reported by: peredozo@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version:
Keywords: try_files, $cookie_ Cc:
uname -a: Linux hosting 5.15.0-73-generic #80-Ubuntu SMP Mon May 15 15:18:26 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.24.0
built by gcc 11.2.0 (Ubuntu 11.2.0-19ubuntu1)
built with OpenSSL 3.0.2 15 Mar 2022
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-g -O2 -ffile-prefix-map=/data/builder/debuild/nginx-1.24.0/debian/debuild-base/nginx-1.24.0=. -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects -fstack-protector-strong -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fPIC' --with-ld-opt='-Wl,-Bsymbolic-functions -flto=auto -ffat-lto-objects -flto=auto -Wl,-z,relro -Wl,-z,now -Wl,--as-needed -pie'

Description

Example 1 (OK)

location / {
	root /path1;
	try_files $uri /index.html;
}

GET / - all ok, i see /index.html content
GET /nofile - all ok, i see /index.html content

Example 2 (BUG)

location / {
	set $todir /path1;
	if ( $cookie_test = 1 ) {
		set $todir /path2;
	}
	root $todir;
	try_files $uri /index.html;
}

GET / - all ok, i see /index.html content
GET /nofile - 404 not found. Where try_files to /index.html redirect? In log:

*1 open() "/path1/nofile" failed (2: No such file or directory)

Seems try_files directive don't works in this case. But why?

Change History (1)

comment:1 by Maxim Dounin, 12 months ago

Resolution: duplicate
Status: newclosed

Duplicate of #86.

Note: See TracTickets for help on using tickets.