Opened 9 months ago

Closed 9 months ago

Last modified 8 months ago

#2520 closed defect (invalid)

Nginx upgrade on debian 11

Reported by: m.camilleri.province@… Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.18.x
Keywords: Cc:
uname -a: Linux nginx01 5.10.0-19-amd64 #1 SMP Debian 5.10.149-2 (2022-10-21) x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.18.0
built with OpenSSL 1.1.1n 15 Mar 2022
TLS SNI support enabled
configure arguments: --with-cc-opt='-g -O2 -ffile-prefix-map=/build/nginx-x3gsRV/nginx-1.18.0=. -fstack-protector-strong -Wformat -Werror=format-security -fPIC -Wdate-time -D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-z,relro -Wl,-z,now -fPIC' --prefix=/usr/share/nginx --conf-path=/etc/nginx/nginx.conf --http-log-path=/var/log/nginx/access.log --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock --pid-path=/run/nginx.pid --modules-path=/usr/lib/nginx/modules --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --with-compat --with-debug --with-pcre-jit --with-http_ssl_module --with-http_stub_status_module --with-http_realip_module --with-http_auth_request_module --with-http_v2_module --with-http_dav_module --with-http_slice_module --with-threads --with-http_addition_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_sub_module

Description

Hello, i've a problem to upgrade Nginx version on Debian 11.7.

I actually have Nginx 1.18 and want to upgrade to the latest stable (1.24)

Here is the problem i have :

The following packages have been kept back:

nginx

0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:

libnginx-mod-http-auth-pam : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-http-dav-ext : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-http-echo : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-http-geoip : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-http-geoip2 : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-http-image-filter : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-http-subs-filter : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-http-upstream-fair : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-http-xslt-filter : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-mail : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-stream : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-stream-geoip : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
libnginx-mod-stream-geoip2 : Depends: nginx-common (= 1.18.0-6.1+deb11u3) but it is not installable
nginx-full : Depends: nginx-core (>= 1.18.0-6.1+deb11u3) but it is not installable

Depends: nginx-core (< 1.18.0-6.1+deb11u3.1~) but it is not installable

E: Broken packages

Can you help me with that or do i have to do a dist-upgrade ?

Change History (1)

comment:1 by Maxim Dounin, 9 months ago

Resolution: invalid
Status: newclosed

If you want to switch from the Debian-provided package to the one from nginx.org, consider uninstalling the Debian-provided package, and then install the one from nginx.org as described here. If you need further help with nginx, please use support options available.

Note: See TracTickets for help on using tickets.