Opened 4 months ago

Closed 4 months ago

#2581 closed defect (duplicate)

quic: virtual host not working

Reported by: Jing Luo Owned by:
Priority: major Milestone: nginx-1.25
Component: http/3 Version: 1.25.x
Keywords: QUIC Cc:
uname -a: Linux load-balancer1 6.5.11-6-pve #1 SMP PREEMPT_DYNAMIC PMX 6.5.11-6 (2023-11-29T08:32Z) x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.25.3
built by gcc 12.2.0 (Debian 12.2.0-14)
built with OpenSSL 3.0.9 30 May 2023 (running with OpenSSL 3.0.11 19 Sep 2023)
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-http_v3_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-g -O2 -ffile-prefix-map=/data/builder/debuild/nginx-1.25.3/debian/debuild-base/nginx-1.25.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fPIC' --with-ld-opt='-Wl,-z,relro -Wl,-z,now -Wl,--as-needed -pie'

Description

I tried to put multiple virtual hosts in the nginx config while enabling quic, but nginx.conf will have validation error if I specify "listen 443 quic resueport" on multiple server blocks:


server {

listen 443 ssl;
listen [::]:443 ssl;
listen 443 quic reuseport;
listen [::]:443 quic reuseport;
http2 on;
http3 on;
http3_hq on;
server_name vhost1;

...
}

server {

listen 443 ssl;
listen [::]:443 ssl;
listen 443 quic reuseport; # ----> validation error
listen [::]:443 quic reuseport; # ----> validation error
http2 on;
http3 on;
http3_hq on;
server_name vhost2;

...
}


# nginx -t

nginx: [emerg] duplicate listen options for 0.0.0.0:443 [...]


If I comment out "listen 443 quic reuseport" in the second server block, then http/3 will only work for vhost1, not working for vhost2, even if "http3 on" is used. I tested this using a Chromium-based browser and curl with http3 enabled at compile time (curl3 --http3-only -v -k https://ip.address/ -H "Host: vhost2").

On the other hand, removing "reuseport" can let the config pass validation but QUIC connection cannot be established at all, http/3 is not working for neither vhost1 nor vhost2.

The nginx binary is downloaded from http://nginx.org/packages/mainline/debian

Change History (1)

comment:1 by Roman Arutyunyan, 4 months ago

Resolution: duplicate
Status: newclosed

Duplicate of #2504

Note: See TracTickets for help on using tickets.