Opened 6 weeks ago

Closed 6 weeks ago

#2592 closed defect (invalid)

Ports are not forwarded

Reported by: ysofty@… Owned by:
Priority: critical Milestone: nginx-1.25
Component: other Version: 1.25.x
Keywords: docker Cc: ysofty@…
uname -a: Linux 6202ae1e7454 6.1.0-13-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.55-1 (2023-09-29) x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.25.3
built by gcc 12.2.0 (Debian 12.2.0-14)
built with OpenSSL 3.0.9 30 May 2023 (running with OpenSSL 3.0.11 19 Sep 2023)
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --sbin-path=/usr/sbin/nginx --modules-path=/usr/lib/nginx/modules --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --pid-path=/var/run/nginx.pid --lock-path=/var/run/nginx.lock --http-client-body-temp-path=/var/cache/nginx/client_temp --http-proxy-temp-path=/var/cache/nginx/proxy_temp --http-fastcgi-temp-path=/var/cache/nginx/fastcgi_temp --http-uwsgi-temp-path=/var/cache/nginx/uwsgi_temp --http-scgi-temp-path=/var/cache/nginx/scgi_temp --user=nginx --group=nginx --with-compat --with-file-aio --with-threads --with-http_addition_module --with-http_auth_request_module --with-http_dav_module --with-http_flv_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_random_index_module --with-http_realip_module --with-http_secure_link_module --with-http_slice_module --with-http_ssl_module --with-http_stub_status_module --with-http_sub_module --with-http_v2_module --with-http_v3_module --with-mail --with-mail_ssl_module --with-stream --with-stream_realip_module --with-stream_ssl_module --with-stream_ssl_preread_module --with-cc-opt='-g -O2 -ffile-prefix-map=/data/builder/debuild/nginx-1.25.3/debian/debuild-base/nginx-1.25.3=. -fstack-protector-strong -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fPIC' --with-ld-opt='-Wl,-z,relro -Wl,-z,now -Wl,--as-needed -pie'

Description

Good afternoon.
I want to connect the nginx container to the macVlan or IPVlan network. At startup, ports 80 and 443 are not forwarded.
Example:

docker network create -d macvlan --subnet 10.8.8.0/24 --gateway 10.8.8.1 -o parent=ens192 MAC_vlan create a macvlan network

docker run -d --name NginX --ip 10.8.8.5 --net MAC_vlan -p 80:80 -p 443:443 nginx start the container

then the container starts, but ports 80 and 443 are not forwarded to the host machine.

The host machine is like this:
Linux docker 6.1.0-13-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.55-1 (2023-09-29) x86_64 GNU/Linux

debian 12

What could be the problem ?

Change History (1)

comment:1 by Maxim Dounin, 6 weeks ago

Resolution: invalid
Status: newclosed

This looks like a question about Docker, and not a bug in nginx. It would be more appropriate to use appropriate Docker support options to ask this question.

Note: See TracTickets for help on using tickets.