Opened 2 months ago

Closed 7 weeks ago

#2606 closed defect (duplicate)

Issues building Nginx using boringssl

Reported by: rttwyjz@… Owned by:
Priority: minor Milestone: nginx-1.25
Component: documentation Version: 1.25.x
Keywords: Cc: rttwyjz@…
uname -a: 6.1.0-18-amd64
nginx -V: nginx version: nginx/1.25.4
built by gcc 12.2.0 (Debian 12.2.0-14)
built with OpenSSL 1.1.1 (compatible; BoringSSL) (running with BoringSSL)
TLS SNI support enabled
configure arguments: --user=www --group=www --prefix=/www/server/nginx --with-pcre --add-module=/root/ngx_brotli --with-http_v2_module --with-stream --with-stream_ssl_module --with-http_ssl_module --with-http_gzip_static_module --with-http_gunzip_module --with-http_sub_module --with-http_flv_module --with-http_addition_module --with-http_realip_module --with-http_mp4_module --with-ld-opt=-Wl,-E --with-cc-opt=-Wno-error --with-ld-opt=-ljemalloc --with-http_dav_module --with-http_v3_module --with-cc-opt=-I../boringssl/include --with-ld-opt='-L../boringssl/build/ssl -L../boringssl/build/crypto'

Description

Hello,
I encountered an error when building Nginx using boringssl. Due to system problems, I cannot post the complete code here. Please check: https://mailman.nginx.org/pipermail/nginx/2024-February/BPUXWLAJVRP7V3QQXU2L3PSP6V4FWZPP. html

Change History (2)

comment:1 by Karthikdasari0423@…, 2 months ago

Thanks for mentioning workaround in https://trac.nginx.org/nginx/ticket/2605
it worked. Hope nginx fixes asap

comment:2 by Roman Arutyunyan, 7 weeks ago

Resolution: duplicate
Status: newclosed

Duplicate of #2605

Note: See TracTickets for help on using tickets.