Opened 6 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#2616 closed defect (worksforme)

apt upgrade fails.

Reported by: aski71@… Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.25.x
Keywords: Cc:
uname -a: Linux butler 5.15.0-97-generic #107-Ubuntu SMP Wed Feb 7 13:26:48 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.18.0 (Ubuntu)
built with OpenSSL 3.0.2 15 Mar 2022
TLS SNI support enabled
configure arguments: --with-cc-opt='-g -O2 -ffile-prefix-map=/build/nginx-zctdR4/nginx-1.18.0=. -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects -fstack-protector-strong -Wformat -Werror=format-security -fPIC -Wdate-time -D_FORTIFY_SOURCE=2' --with-ld-opt='-Wl,-Bsymbolic-functions -flto=auto -ffat-lto-objects -flto=auto -Wl,-z,relro -Wl,-z,now -fPIC' --prefix=/usr/share/nginx --conf-path=/etc/nginx/nginx.conf --http-log-path=/var/log/nginx/access.log --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock --pid-path=/run/nginx.pid --modules-path=/usr/lib/nginx/modules --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --with-compat --with-debug --with-pcre-jit --with-http_ssl_module --with-http_stub_status_module --with-http_realip_module --with-http_auth_request_module --with-http_v2_module --with-http_dav_module --with-http_slice_module --with-threads --add-dynamic-module=/build/nginx-zctdR4/nginx-1.18.0/debian/modules/http-geoip2 --with-http_addition_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_sub_module

Description

Hi,
I can't upgrade to the 1.24.0 stable version which is offered to me by apt.

nginx was set up using the stable version and preferring the nginx repository rather than the distribution one as described here:
https://nginx.org/en/linux_packages.html#Ubuntu

This worked perfectly.
Now apt is offering to upgrade to 1.24.0.

The following is happening:
$ sudo apt upgrade nginx
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:

libnginx-mod-http-geoip2 : Depends: nginx-common (= 1.18.0-6ubuntu14.4) but it is not installable
libnginx-mod-http-image-filter : Depends: nginx-common (= 1.18.0-6ubuntu14.4) but it is not installable
libnginx-mod-http-xslt-filter : Depends: nginx-common (= 1.18.0-6ubuntu14.4) but it is not installable
libnginx-mod-mail : Depends: nginx-common (= 1.18.0-6ubuntu14.4) but it is not installable
libnginx-mod-stream : Depends: nginx-common (= 1.18.0-6ubuntu14.4) but it is not installable
libnginx-mod-stream-geoip2 : Depends: nginx-common (= 1.18.0-6ubuntu14.4) but it is not installable

E: Broken packages

What can be done?

Change History (2)

comment:1 by thresh, 6 weeks ago

Resolution: worksforme
Status: newclosed

Hello!

The reason for that error is nginx.org packages are incompatible with the ones provided by Ubuntu repos.

Looks like apt still prefers the Ubuntu repos ones when you issue apt upgrade nginx. Please try apt install nginx as per the documentation - it seems to work here just fine. It will remove the offending packages, and install nginx.org-provided packages.

comment:2 by aski71@…, 6 weeks ago

Thank you! I wasn't aware that "apt upgrade" doesn't work. "apt install" did!

Note: See TracTickets for help on using tickets.