Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#278 closed defect (duplicate)

Nginx stops processes after reload procedure

Reported by: Акулов Андрей Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.3.x
Keywords: reload error Cc:
uname -a: Linux floyd 2.6.18-308.24.1.el5PAE #1 SMP Tue Dec 4 18:28:32 EST 2012 i686 i686 i386 GNU/Linux
nginx -V: nginx version: nginx/1.3.10
built by gcc 4.1.2 20080704 (Red Hat 4.1.2-52)
TLS SNI support disabled
configure arguments: --user=nginx --group=nginx --prefix=/usr/share/nginx --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/tmp/client_body --http-proxy-temp-path=/var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=/var/lib/nginx/tmp/fastcgi --http-uwsgi-temp-path=/var/lib/nginx/tmp/uwsgi --http-scgi-temp-path=/var/lib/nginx/tmp/scgi --pid-path=/var/run/nginx.pid --lock-path=/var/lock/subsys/nginx --with-http_secure_link_module --with-http_random_index_module --with-http_ssl_module --with-http_realip_module --with-http_addition_module --with-http_sub_module --with-http_dav_module --with-http_flv_module --with-http_mp4_module --with-http_gzip_static_module --with-http_degradation_module --with-http_stub_status_module --with-http_perl_module --with-http_geoip_module --with-mail --with-mail_ssl_module --with-cc-opt='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables' --with-ipv6 --with-file-aio --add-module=/builddir/build/BUILD/nginx-1.3.10/nginx-upstream-fair --add-module=/builddir/build/BUILD/nginx-1.3.10/nginx-upload-progress-module --add-module=/builddir/build/BUILD/nginx-1.3.10/mod_zip-1.1.6 --add-module=/builddir/build/BUILD/nginx-1.3.10/ngx_http_auth_pam_module-1.2 --add-module=/builddir/build/BUILD/nginx-1.3.10/nginx-upload-module-2.2

Description

We having nginx as a frontend to many sites. Every site has own conf file. All files are included into nginx config.

After making changes in certain site conf we always do "/etc/init.d/nginx reload". Nginx reloads, write that all is correct. But the error.log starts to fill with lines:

2013/01/09 13:50:04 [alert] 1968#0: worker process 2046 exited on signal 11
2013/01/09 13:50:04 [alert] 1968#0: worker process 2041 exited on signal 11
2013/01/09 13:50:05 [alert] 1968#0: worker process 2049 exited on signal 11
2013/01/09 13:50:06 [alert] 1968#0: worker process 2065 exited on signal 11
2013/01/09 13:50:06 [alert] 1968#0: worker process 2074 exited on signal 11
2013/01/09 13:50:07 [alert] 1968#0: worker process 2071 exited on signal 11
2013/01/09 13:50:08 [alert] 1968#0: worker process 2047 exited on signal 11
2013/01/09 13:50:10 [alert] 1968#0: worker process 2043 exited on signal 11
2013/01/09 13:50:11 [alert] 1968#0: worker process 2081 exited on signal 11
2013/01/09 13:50:11 [alert] 1968#0: worker process 2044 exited on signal 11
2013/01/09 13:50:11 [alert] 1968#0: worker process 2045 exited on signal 11
2013/01/09 13:50:12 [alert] 1968#0: worker process 2078 exited on signal 11
2013/01/09 13:50:13 [alert] 1968#0: worker process 2126 exited on signal 11

And error 324 (EMPTY RESPONSE) appears on random pages.

Everything works fine after making "/etc/init.d/nginx restart"

The problem appeared after upgrade to version 1.3.10. Previous installed version 1.3.8 has no problem.

Change History (2)

comment:1 by Maxim Dounin, 7 years ago

Resolution: duplicate
Status: newclosed

Thank you for your report. This is believed to be duplicate of #268, fix is r5002.

in reply to:  1 comment:2 by Акулов Андрей, 7 years ago

Replying to Maxim Dounin:

Thank you for your report. This is believed to be duplicate of #268, fix is r5002.

Ok. Will wait next release. Thank you.

Note: See TracTickets for help on using tickets.