Opened 7 years ago

Closed 7 years ago

#336 closed defect (duplicate)

nginx could not be built with the ngx_http_perl_module if the --with-openssl option was used

Reported by: Hien Phan Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.3.x
Keywords: Cc:
uname -a: Linux 2.6.32-5-amd64 #1 SMP Mon Feb 25 00:26:11 UTC 2013 x86_64 GNU/Linux
nginx -V: ./configure --prefix=/opt/nginx --with-http_realip_module --with-pcre --with-file-aio --with-ipv6 --with-http_perl_module --with-http_stub_status_module --with-openssl=/opt/src/openssl-1.0.1e --with-openssl-opt=enable-tlsext --with-http_ssl_module --with-http_spdy_module

Description

Hello,

I tried to build Nginx 1.3.16 with OpenSSL 1.0.1e on Debian 6, I got below error:

src/http/modules/ngx_http_upstream_keepalive_module.c

cc -c -pipe -O -W -Wall -Wpointer-arith -Wno-unused-parameter -Werror -g -I src/core -I src/event -I src/event/modules -I src/os/unix -I /opt/src/openssl-1.0.1e/.openssl/include -I objs -I src/http -I src/http/modules -I src/http/modules/perl \

-o objs/src/http/modules/ngx_http_stub_status_module.o \
src/http/modules/ngx_http_stub_status_module.c

cc -c -pipe -O -W -Wall -Wpointer-arith -Wno-unused-parameter -Werror -g -I src/core -I src/event -I src/event/modules -I src/os/unix -I /opt/src/openssl-1.0.1e/.openssl/include -I objs \

-o objs/ngx_modules.o \
objs/ngx_modules.c

cd objs/src/http/modules/perl && make
make[2]: Entering directory `/opt/src/nginx-1.3.16/objs/src/http/modules/perl'
make[2]: * No rule to make target ../../../../..//opt/src/openssl-1.0.1e//.openssl/include/openssl/ssl.h', needed by nginx.c'. Stop.
make[2]: Leaving directory `/opt/src/nginx-1.3.16/objs/src/http/modules/perl'
make[1]:
* [objs/src/http/modules/perl/blib/arch/auto/nginx/nginx.so] Error 2
make[1]: Leaving directory `/opt/src/nginx-1.3.16'
make: * [build] Error 2

Change History (1)

comment:1 by Maxim Dounin, 7 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #334.

Note: See TracTickets for help on using tickets.