Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#347 closed defect (fixed)

upstream keepalive not working for HTTPS

Reported by: Roy Reznik Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.2.x
Keywords: Cc:
uname -a: Linux lnxmachine2 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:13:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.2.8
built by gcc 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
TLS SNI support enabled
configure arguments: --with-http_stub_status_module --with-http_ssl_module --with-ld-opt=-lossp-uuid --with-cc-opt=-I/usr/include/ossp --add-module=../ngx_http_gunzip_filter_module --add-module=../ngx_devel_kit-0.2.18 --add-module=../clean-lua-nginx-module --add-module=../nginx-x-rid-header --with-cc=gcc --sbin-path=/usr/sbin/nginx --conf-path=/etc/nginx/nginx.conf --pid-path=/var/run/nginx.pid --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log

Description

upstream server_1 {

server serverhost.domain.com:443;
keepalive 32;

}

location /proxy {

# Remove the /proxy prefix.
rewrite /proxy/(.*) /$1 break; # break is necessary within a location. See the rewrite module docs.

proxy_buffer_size 128k;
proxy_buffers 4 256k;
proxy_busy_buffers_size 256k;

proxy_http_version 1.1;
proxy_set_header Connection "";
proxy_ssl_session_reuse on;

proxy_buffering off;
proxy_pass https://server_1;

}

However when looking in tshark - I can see SSL handshake with the backend server for each request, which means the connection is not kept alive...

This causes a really big performance issue when using backend SSL servers.

Change History (3)

comment:1 by Roy Reznik, 7 years ago

You can close this issue
It was fixed in 1.4.0.

Cheers.

comment:2 by maxim, 7 years ago

Resolution: fixed
Status: newclosed

comment:3 by maxim, 7 years ago

The submitter reports that the issue is fixed in the recent version of nginx.

Note: See TracTickets for help on using tickets.