Opened 7 years ago

Closed 7 years ago

#349 closed defect (invalid)

HTTP_STATUS never set to YES?

Reported by: Daniel Griscom Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.3.x
Keywords: Cc:
uname -a: Darwin macbookpro.home 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun 7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386
nginx -V: nginx version: nginx/1.4.0

Description

Looking at auto/options, there is a default for each of the HTTP_XXXXX variables, as well as a "--with(out)_http_xxxxx" option to change the default. However, the value of HTTP_STATUS defaults to NO, and the only related option is --without-http_status_module, which (no surprise) also sets HTTP_STATUS to NO. Is this a bug? (Found in version 1.4.0.)

Change History (1)

comment:1 by Maxim Dounin, 7 years ago

Resolution: invalid
Status: newclosed

No, this is not a bug. The variable and the option is expected to be used once ngx_http_status_module will actually appear.

Note: See TracTickets for help on using tickets.