Opened 7 years ago

Closed 6 years ago

#385 closed defect (invalid)

Nginx 1.5.2 with spdy as forward proxy, part of site page can't be loaded

Reported by: fan nba Owned by:
Priority: critical Milestone:
Component: nginx-module Version: 1.3.x
Keywords: Cc:
uname -a: Linux linux-fast-1 2.6.32.45-0.3.2.3813.0.PTF-default #1 SMP 2011-08-22 10:12:58 +0200 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.5.2
built by gcc 4.3.4 [gcc-4_3-branch revision 152973] (SUSE Linux)
configure arguments: --prefix=/home/tianxin/nginx1.5.2_Test/nginx1.5.2 --sbin-path=/home/tianxin/nginx1.5.2_Test/nginx1.5.2/sbin/nginx --conf-path=/home/tianxin/nginx1.5.2_Test/nginx1.5.2/nginx.conf --pid-path=/home/tianxin/nginx1.5.2_Test/nginx1.5.2/nginx.pid --error-log-path=/home/tianxin/nginx1.5.2_Test/nginx1.5.2/log/error.log --http-log-path=/home/tianxin/nginx1.5.2_Test/nginx1.5.2/log/access.log --with-poll_module --with-pcre=/home/tianxin/nginx1.5.2_Test/pcre-8.31 --with-pcre-jit --with-zlib=/home/tianxin/nginx1.5.2_Test/zlib-1.2.7 --with-debug --with-http_spdy_module

Description

when using chrome brower visit site www.taobao.com pass by nginx 1.5.2 with spdy as forward proxy, part of page can't be loaded; and the same scene also appeared when using nginx with spdy as reverse proxy.

Attachments (3)

picture1.rar (194.1 KB ) - added by fan nba 7 years ago.
screenshot 1
picture2.rar (170.8 KB ) - added by fan nba 7 years ago.
screenshot 2
nginx.conf (1.9 KB ) - added by fan nba 7 years ago.

Download all attachments as: .zip

Change History (4)

by fan nba, 7 years ago

Attachment: picture1.rar added

screenshot 1

by fan nba, 7 years ago

Attachment: picture2.rar added

screenshot 2

by fan nba, 7 years ago

Attachment: nginx.conf added

comment:1 by Valentin V. Bartenev, 6 years ago

Resolution: invalid
Status: newclosed

It looks like Chrome problem. I'm able to reproduce it with shrpx as well.

My test chain:

Chromium 28.0.1500.95 <-> shrpx 1.0.0 <-> nginx 1.5.4 <--> www.taobao.com

Results:

Protocol
Chromium <-> shrpx shrpx <-> nginx Page loaded
SPDY SPDY Partially
SPDY HTTP Partially
HTTP SPDY Completely
Note: See TracTickets for help on using tickets.