Opened 7 years ago

Closed 7 years ago

#403 closed defect (invalid)

SPDY: image requests to same host but different domain very slow

Reported by: Steffen Weber Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.3.x
Keywords: Cc:
uname -a: Linux 3.10.9 #15 SMP Fri Aug 23 12:09:48 CEST 2013 x86_64 Intel(R) Core(TM)2 Duo CPU T9400 @ 2.53GHz GenuineIntel GNU/Linux
nginx -V: nginx version: nginx/1.4.2
TLS SNI support enabled
configure arguments: --prefix=/usr --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error_log --pid-path=/run/nginx.pid --lock-path=/run/lock/nginx.lock --with-cc-opt=-I/usr/include --with-ld-opt=-L/usr/lib --http-log-path=/var/log/nginx/access_log --http-client-body-temp-path=//var/lib/nginx/tmp/client --http-proxy-temp-path=//var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=//var/lib/nginx/tmp/fastcgi --http-scgi-temp-path=//var/lib/nginx/tmp/scgi --http-uwsgi-temp-path=//var/lib/nginx/tmp/uwsgi --with-ipv6 --with-pcre --without-http_autoindex_module --without-http_browser_module --without-http_geo_module --without-http_limit_conn_module --without-http_map_module --without-http_memcached_module --without-http_scgi_module --without-http_ssi_module --without-http_split_clients_module --without-http_upstream_ip_hash_module --without-http_userid_module --without-http_uwsgi_module --with-http_gunzip_module --with-http_gzip_static_module --with-http_mp4_module --with-http_secure_link_module --with-http_spdy_module --with-http_stub_status_module --with-http_sub_module --with-http_realip_module --with-http_ssl_module --without-mail_imap_module --without-mail_pop3_module --without-mail_smtp_module --user=nginx --group=nginx

Description

A few weeks ago I filed the following bug report at Mozilla: https://bugzilla.mozilla.org/show_bug.cgi?id=903484

Now I've noticed that the problem only happens when the server is nginx. If I replace nginx 1.4.2 with Apache 2.2.25 + mod_spdy 0.9.3.3 then the problem goes away. So maybe this is a bug in nginx and not in Firefox.

Could you please have a look? All the details are available in Bugzilla.

Change History (5)

comment:1 by Valentin V. Bartenev, 7 years ago

Looks like a problem with your nginx configuration. Could you provide it?

comment:2 by Steffen Weber, 7 years ago

Yes, of course.

1) nginx instance that serves a1.betabase.de and a1.betabase.de:

user nginx nginx;
worker_processes 1;

error_log /var/log/nginx/error_log info;

events {
        worker_connections 1024;
}

http {
        include /etc/nginx/mime.types;
        default_type application/octet-stream;
        index index.html;

        server {
                listen [::]:443 ipv6only=off ssl spdy;
                server_name a1.betabase.de;

                ssl on;
                ssl_certificate /etc/ssl/nginx/nginx.pem;
                ssl_certificate_key /etc/ssl/nginx/nginx.key;

                access_log /var/log/nginx/a1.access_log;
                error_log /var/log/nginx/a1.error_log info;

                root /var/www/a1/htdocs;
        }

        server {
                listen [::]:443 ssl spdy;
                server_name a2.betabase.de;

                ssl on;
                ssl_certificate /etc/ssl/nginx/nginx.pem;
                ssl_certificate_key /etc/ssl/nginx/nginx.key;

                access_log /var/log/nginx/a2.access_log;
                error_log /var/log/nginx/a2.error_log info;

                root /var/www/a2/htdocs;
        }
}

2) nginx instance that serves b.betabase.de: (not required to reproduce the problem, but posted nevertheless for completeness)

user nginx nginx;
worker_processes 1;

error_log /var/log/nginx/error_log info;

events {
        worker_connections 1024;
}

http {
        include /etc/nginx/mime.types;
        default_type application/octet-stream;
        index index.html;

        server {
                listen [::]:443 ipv6only=off ssl spdy;
                server_name b.betabase.de;

                ssl on;
                ssl_certificate /etc/ssl/nginx/nginx2.pem;
                ssl_certificate_key /etc/ssl/nginx/nginx2.key;

                access_log /var/log/nginx/b.access_log;
                error_log /var/log/nginx/b.error_log info;

                root /var/www/b/htdocs;
        }
}
Last edited 7 years ago by Steffen Weber (previous) (diff)

comment:3 by Steffen Weber, 7 years ago

Have you been able to reproduce the problem?

comment:4 by Steffen Weber, 7 years ago

The Mozilla bug has been fixed: https://bugzilla.mozilla.org/show_bug.cgi?id=903484

So I guess this bug can be closed.

comment:5 by Valentin V. Bartenev, 7 years ago

Resolution: invalid
Status: newclosed

Ok, closing.

Note: See TracTickets for help on using tickets.