Opened 7 years ago

Closed 7 years ago

#415 closed defect (invalid)

auto/unix syntax errors with /bin/sh lines

Reported by: Oleg Vinichenko Owned by:
Priority: minor Milestone:
Component: nginx-core Version: 1.3.x
Keywords: Cc:
uname -a: Linux oleg.funtoo.org 2.6.32-042stab059.7 #1 SMP Sat Sep 8 17:04:23 Local time zone must be set--see zic m x86_64 Intel(R) Xeon(R) CPU E5530 @ 2.40GHz GenuineIntel GNU/Linux
nginx -V: nginx version: nginx/1.4.1
TLS SNI support enabled
configure arguments: --prefix=/usr --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error_log --pid-path=/run/nginx.pid --lock-path=/run/lock/nginx.lock --with-cc-opt=-I/usr/include --with-ld-opt=-L/usr/lib --http-log-path=/var/log/nginx/access_log --http-client-body-temp-path=//var/lib/nginx/tmp/client --http-proxy-temp-path=//var/lib/nginx/tmp/proxy --http-fastcgi-temp-path=//var/lib/nginx/tmp/fastcgi --http-scgi-temp-path=//var/lib/nginx/tmp/scgi --http-uwsgi-temp-path=//var/lib/nginx/tmp/uwsgi --with-ipv6 --with-pcre --with-http_realip_module --with-http_ssl_module --without-mail_imap_module --without-mail_pop3_module --without-mail_smtp_module --user=nginx --group=nginx

Description

runnning auto/unix shows syntax errors with /bin/sh lines. This reproducible with bash and zsh (if /bin/sh symlinks to corresponding shell).

Attachments (1)

auto-unix.log (12.4 KB ) - added by Oleg Vinichenko 7 years ago.
auto/unix log

Download all attachments as: .zip

Change History (2)

by Oleg Vinichenko, 7 years ago

Attachment: auto-unix.log added

auto/unix log

comment:1 by Maxim Dounin, 7 years ago

Resolution: invalid
Status: newclosed

The auto/unix script is not intended to be run directly, outside of the configure process. Run the "configure" script instead.

Note: See TracTickets for help on using tickets.