Opened 6 years ago

Closed 6 years ago

#547 closed defect (duplicate)

Nginx worker randomly segfault during the day using owncloud android sync client

Reported by: Arnaud B. Owned by:
Priority: minor Milestone: 1.5
Component: nginx-core Version: 1.5.x
Keywords: segfault Cc:
uname -a: Linux meuh 3.10.23-xxxx-std-ipv6-64 #1 SMP Mon Dec 9 18:53:52 CET 2013 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.2.1
TLS SNI support enabled
configure arguments: --prefix=/etc/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-log-path=/var/log/nginx/access.log --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --lock-path=/var/lock/nginx.lock --pid-path=/var/run/nginx.pid --with-pcre-jit --with-debug --with-http_addition_module --with-http_dav_module --with-http_geoip_module --with-http_gzip_static_module --with-http_image_filter_module --with-http_realip_module --with-http_stub_status_module --with-http_ssl_module --with-http_sub_module --with-http_xslt_module --with-ipv6 --with-sha1=/usr/include/openssl --with-md5=/usr/include/openssl --with-mail --with-mail_ssl_module --add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-auth-pam --add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-echo --add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-upstream-fair --add-module=/tmp/buildd/nginx-1.2.1/debian/modules/nginx-dav-ext-module

Description

Note : I downgraded my Nginx version from 1.4 to 1.2.1 in order to use nginx-full-dbg :



gdb /usr/sbin/nginx /tmp/core 
GNU gdb (GDB) 7.4.1-debian
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/sbin/nginx...Reading symbols from /usr/lib/debug/usr/sbin/nginx...done.
done.
[New LWP 28638]

warning: Can't read pathname for load map: Erreur d'entrée/sortie.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `nginx: worker pr'.
Program terminated with signal 11, Segmentation fault.
#0  ngx_ssl_new_session (ssl_conn=0x78b470, sess=0x7816d0)
    at src/event/ngx_event_openssl.c:1662
1662	src/event/ngx_event_openssl.c: Aucun fichier ou dossier de ce type.
(gdb) backtrace full
#0  ngx_ssl_new_session (ssl_conn=0x78b470, sess=0x7816d0)
    at src/event/ngx_event_openssl.c:1662
        len = 144
        p = 0x70bc20 "\001\003"
        id = <optimized out>
        cached_sess = <optimized out>
        ssl_ctx = 0x0
        shm_zone = 0x0
        c = 0xba01f718307a1500
        shpool = <optimized out>
        sess_id = <optimized out>
        cache = <optimized out>
        buf = "\220\000\000\000\000\000\000\000 2\342\210-\177\000\000\002\000\000\000\000\000\000\000 \274p\000\000\000\000\000\220\000\000\000\000\000\000\000\215\240B", '\000' <repeats 13 times>"\200, \027\342\210-\177\000\000\003\000\000\000\000\000\000\000\317\000\354\210-\177\000\000p.v\000\000\000\000\000\004\000\000\000\000\000\000\000`Ju\000\000\000\000\000\020\243i\203-\177\000\000\003\000\000\000\000\000\000\000 \237\200f\377\177\000\000\060\201\215\002\001\001\002\002\003\001\004\002\000\004\004 \274\353\266\364\365\207\"\277\355\315\277\250\260\374\234-rl\216\335A\305\371\266\244nu\n2\345\250'\004\060*\345\b^$\226,\371\213\251\023\035;\277{\347\357\005\n\035\350\257\016\277*\211\231\330b;4&\214^ /\353\254I&\334\375+\207%\035\066\061\241\006\002\004SY\037\246\242\004\002\002\001,\244\006\004\004HTTP\246\026\004\024owncloud.arnaudb."...
#1  0x00007f2d891dae6e in ?? ()
   from /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0
No symbol table info available.
#2  0x00007f2d891e9de2 in ?? ()
   from /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0
No symbol table info available.
#3  0x000000000070bce0 in ?? ()
No symbol table info available.
#4  0xba01f718307a1500 in ?? ()
No symbol table info available.
#5  0x0000000000000003 in ?? ()
No symbol table info available.
---Type <return> to continue, or q <return> to quit---*
#6  0x000000000070ac00 in ?? ()
No symbol table info available.
#7  0x0000000000000002 in ?? ()
No symbol table info available.
#8  0x0000000000000302 in ?? ()
No symbol table info available.
#9  0x0000000000000002 in ?? ()
No symbol table info available.
#10 0x0000000000000000 in ?? ()
No symbol table info available.
(gdb) 
(gdb) quit

Change History (1)

comment:1 by Maxim Dounin, 6 years ago

Resolution: duplicate
Status: newclosed

Looks like a duplicate of #235. Please follow workaround suggested (that is, move ssl_session_cache to http{} level).

Note: See TracTickets for help on using tickets.