Opened 6 years ago

Closed 6 years ago

#577 closed defect (invalid)

30000 worker_connections are not enough

Reported by: Edward Hibbert Owned by:
Priority: major Milestone:
Component: nginx-core Version: 1.5.x
Keywords: worker connections not enough Cc:
uname -a: Linux fd1.vlan2116.freegle.uk0.bigv.io 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
nginx -V: nginx version: nginx/1.4.4
built by gcc 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu9)
TLS SNI support enabled
configure arguments: --add-module=nginx_http_push_module --with-ipv6 --with-http_ssl_module --with-debug --with-http_stub_status_module --sbin-path=/usr/sbin --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --pid-path=/var/run/nginx.pid --lock-path=/var/lock/nginx.lock --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/body --http-proxy-temp-path=/var/lib/nginx/proxy --http-fastcgi-temp-path=/var/lib/nginx/fastcgi

Description

I've got an nginx server which stops working around once a week with this error. Restarting nginx cures it. Any suggestions?

I've got OS configuration set to allow many file handles. Here's the config:

user www-data;
worker_processes 10;
worker_rlimit_nofile 50000;

pid /var/run/nginx.pid;

events {

worker_connections 30000;
multi_accept on;

}

http {

##
# Basic Settings
##

sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
types_hash_max_size 2048;

# server_tokens off;

push_stream_shared_memory_size 100M;

client_max_body_size 10m;
client_body_buffer_size 16k;

server_names_hash_bucket_size 64;

Change History (3)

comment:1 by Valentin V. Bartenev, 6 years ago

Please update your nginx to the supported version, and try to reproduce the issue without 3rd-party modules.

comment:2 by Edward Hibbert, 6 years ago

Thanks, I hadn't realised quite how old my version was.

comment:3 by Maxim Dounin, 6 years ago

Resolution: invalid
Status: newclosed

I suspect it's actually related to the push_stream 3rd party module used - either its leaking sockets for some reason, or it's just a normal load which reaches the limit. Anyway, doesn't looks like an issue in nginx itself.

Note: See TracTickets for help on using tickets.